UVA 465 Overflow

Overflow

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (type integer if you are working Pascal, type intif you are working in C).

Input

An unspecified number of lines. Each line will contain an integer, one of the two operators+ or *, and another integer.

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big'', ``second number too big'', ``result too big''.

Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big
 

题意:

给一个表达式,判断这两个数与表达式的结果是否有大于 int 最大值的,

刚开始理解错了题意,WA好多次!double 保存结果,不超。

代码:

#include <cstdio>
#include <cstring>
#include<climits>       // INT_MAX 需要

int main()
{
    char s1[1000], s2[1000], ch;
    int la, lb;
    while( ~scanf("%s %c %s", &s1, &ch, &s2)  ) {
        double sum1 = 0, sum2 = 0;
        la = strlen(s1);
        lb = strlen(s2);
        for(int i = 0; i < la; i++) sum1 = 10 * sum1 + s1[i] - '0';
        for(int i = 0; i < lb; i++) sum2 = 10 * sum2 + s2[i] - '0';
        printf("%s %c %s\n", s1, ch, s2);
        if(sum1 > INT_MAX) printf("first number too big\n");
        if(sum2 > INT_MAX) printf("second number too big\n");
        if(ch == '+') sum1 += sum2 ;
        if(ch == '*') sum1 *= sum2 ;
        if(sum1 > INT_MAX) printf("result too big\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值