经典 数学问题 Fibonacci Numbers

22 篇文章 0 订阅

Fibonacci Numbers

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 6
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

The Fibonacci sequence is the sequence of numbers such that every element is equal to the sum of the two previous elements, except for the first two elements f0 and f1 which are respectively zero and one.

What is the numerical value of the nth Fibonacci number?

Input

For each test case, a line will contain an integer i between 0 and 10 8 inclusively, for which you must compute the ith Fibonacci number fi. Fibonacci numbers get large pretty quickly, so whenever the answer has more than 8 digits, output only the first and last 4 digits of the answer, separating the two parts with an ellipsis (“...”). 

There is no special way to denote the end of the of the input, simply stop when the standard input terminates (after the EOF).

Sample Input

0
1
2
3
4
5
35
36
37
38
39
40
64
65

Sample Output

0
1
1
2
3
5
9227465
14930352
24157817
39088169
63245986
1023...4155
1061...7723
1716...7565

Source

IPCP 2005 Northern Preliminary for Northeast North-America


对于斐波那契数列来讲,有个万能公式,F(n)=(1/√5)*{[(1+√5)/2]^n - [(1-√5)/2]^n}。对于后四位数来讲,它的循环周期是15000(从网上看到的),当n<40的时候,直接打表即可们因为不超过四位数。当n>=40的时候,对于后四位,将15000内的数列打表,对于前四位数,可以(这里有个坑,若是直接套这个公式将结果存入double中也会造成溢出。。。所以需要化简,但是式子有些复杂又不好化简,好在只需要求前4位,对精度要求不是太高,所以把(1-√5)/2这一项去掉不影响结果)直接使用万能公式,并且用科学计数法表示。x=log10(1/sqrt(5)),y=log10((1+sqrt(5))/2);那么log10(fn)=x+n*y;然后就可以用科学计数法来求出前四位。

附代码:

#include<stdio.h>
#include<math.h>
int n;
int fib[40];//准备前40 个斐波那契数列 
int cci[15010];
const double x=log10(1.0/sqrt(5.0));
const double y=log10((1.0+sqrt(5.0))/2.0);
int main()
{
	int i;
	fib[0]=0;
	fib[1]=1;
	cci[0]=0;
	cci[1]=1;
	for(i=2;i<40;i++)
	   fib[i]=fib[i-1]+fib[i-2];
	for(i=2;i<=15000;i++)
	{
		cci[i]=cci[i-1]+cci[i-2];
		if(cci[i]>=10000)//只需要后四位 
		 cci[i]%=10000; 
	}
	while(scanf("%d",&n)!=EOF)
	{
		if(n<40)
		{
			printf("%d\n",fib[n]);
			continue;
		}
		  
		double res;
		 res=x+n*y;
		 res-=(int)res;
		 res=pow(10,res)*1000;
		 printf("%d...%0.4d\n",(int)res,cci[n%15000]);//1500是一个循环周期 
	}                                     //输出时可能不足四位,注意补 0 
return 0; 
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值