CDOJ 1222--Sudoku【DFS && 数独】

Sudoku

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
 

Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.

Actually, Yi Sima was playing it different. First of all, he tried to generate a  4×4  board with every row contains  1  to  4 , every column contains  1  to  4 . Also he made sure that if we cut the board into four  2×2  pieces, every piece contains  1  to  4 .

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.

Actually, you are seeing this because you've passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!

Input

The first line of the input gives the number of test cases,  T ( 1T100 ).  T  test cases follow. Each test case starts with an empty line followed by  4  lines. Each line consist of  4  characters. Each character represents the number in the corresponding cell (one of 1234). * represents that number was removed by Yi Sima.

It's guaranteed that there will be exactly one way to recover the board.

Output

For each test case, output one line containing Case #x:, where  x  is the test case number (starting from  1 ). Then output  4  lines with  4  characters each. indicate the recovered board.

Sample input and output

Sample Input Sample Output
3

****
2341
4123
3214

*243
*312
*421
*134

*41*
**3*
2*41
4*2*
Case #1:
1432
2341
4123
3214
Case #2:
1243
4312
3421
2134
Case #3:
3412
1234
2341
4123

Source

The 2015 China Collegiate Programming Contest


解析:数独填数,直接暴力DFS即可

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int d;
struct node{
    int x, y;
};
node str[50];
bool vish[5][5];
bool visl[5][5];
bool visk[5][5];
char map[5][5];

int change (int x, int y){
    return x /2 * 2 + y / 2;
}

void dfs(int k){
    if(k == d){
        for(int i = 0; i < 4; ++i){
            printf("%s\n", map[i]);
        }
        return ;
    }

    for(int i = 1; i <= 4; ++i){
            int t = change(str[k].x, str[k].y);
         if(!vish[str[k].x][i] && !visl[str[k].y][i] && !visk[t][i]){
            map[str[k].x][str[k].y] = i + '0';
            vish[str[k].x][i] = 1;
            visl[str[k].y][i] = 1;
            visk[t][i] = 1;
            dfs(k + 1);
            vish[str[k].x][i] = 0;
            visl[str[k].y][i] = 0;
            visk[t][i] = 0;
            map[str[k].x][str[k].y] = '*';
         }
    }
}

int kcase;
int main (){
    int T;
    kcase = 1;
    scanf("%d", &T);
    while(T--){
        d = 0;
        memset(vish, 0, sizeof(vish));
        memset(visl, 0, sizeof(visl));
        memset(visk, 0, sizeof(visk));
        for(int i = 0; i < 4; ++i){
            scanf("%s", map[i]);
            for(int j = 0; j < 4; ++j)
                if(map[i][j] != '*'){
                    vish[i][map[i][j] - '0'] = 1;
                    visl[j][map[i][j] - '0'] = 1;
                    visk[change(i, j)][map[i][j] - '0'] = 1;
                }
                else {
                    str[d].x = i;
                    str[d].y = j;
                    d++;
                }
        }
        printf("Case #%d:\n", kcase++);
        dfs(0);
    }
    return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值