4 Values whose Sum is 0 POJ - 2785(折半枚举)题解


题目描述:

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).


abcd四个序列,找出a[i]+b[j]+c[k]+d[l]=0的所有可能组合。
若是四重循环枚举,则复杂度为n^4,肯定超时。若是先枚举a和b获得所有a[i]+b[j]的可能存入数组add,然后枚举c和d,通过二分寻找add中有没有存在x(数量不唯一)使得x+c[i]+d[j]=0,复杂度降为O(n^2logn).
upper_bound(数组头,数组尾,x)获得大于x的第一个数的位置,
lower_bound(数组头,数组尾,x)获得大于等于x的第一个数的位置。则upper_bound(数组头,数组尾,x)-lower_bound(数组头,数组尾,x)就能得到数组中等于x的元素的数量。

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
const int maxn = 4000;
int n;
int a[maxn], b[maxn], c[maxn], d[maxn], add[maxn*maxn];
int main(){
    while (~scanf("%d", &n)){
        for (int i = 0; i < n; i++){
            scanf("%d%d%d%d", &a[i], &b[i], &c[i], &d[i]);
        }
        for (int i = 0; i < n; i++){
            for (int j = 0; j < n; j++){
                add[i*n + j] = a[i] + b[j];
            }
        }
        long long ans = 0;
        sort(add, add + n*n);
        for (int i = 0; i < n; i++){
            for (int j = 0; j < n; j++){
                int cnt =-(c[i] + d[j]);
                ans += upper_bound(add, add + n*n, cnt) - lower_bound(add, add + n*n, cnt);
            }
        }
        printf("%lld\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值