HDU1157 Who's in the Middle

                                              Who's in the Middle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7034    Accepted Submission(s): 3432


Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

Input
* Line 1: A single integer N

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

Output
* Line 1: A single integer that is the median milk output.
 

Sample Input
  
  
5 2 4 1 3 5
 

Sample Output
  
  
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
 

Source
 

Recommend
mcqsmall


解题思路:好吧,我表示我很邪恶,拿了老师给的动归题用库函数直接排序做了,不知道用sort()排序会不会超时呢?恩,等会试一下。
思路,简单啦,中位数吗,直接把数列排序就好了,直接去中间的那一位数输出即可啦!


014638762013-07-29 10:53:42Accepted10060 MS352 KBVisual C++try it
效果不可思意的好,本来以为有可能超时,没想到竟然0ms飘过,STL强大啊!


#include<stdio.h>
#include<queue>
using namespace std;
int main()
{
    int n,i,x;
    priority_queue<int> q;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
        {
            scanf("%d",&x);
            q.push(x);   //直接进入优先队列
        }
        n/=2;
        for(i=0;i<n;i++)  //弹出前n/2个数
            q.pop();
        printf("%d\n",q.top()); //直接输出即可,排序后第n/2+1个数,即中位数
        q.pop();   //把队列中得元素全部弹出,以免影响下一个测试数据{要是优先队列能有个清空队列的方法,就方便省时了}
        for(i=0;i<n;i++)
            q.pop();
    }
    return 0;
}


87501792013-07-29 11:09:21Accepted11570MS312K286 BC++try it


#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int n,i;
    int a[10000];
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n);           //直接排序
        printf("%d\n",a[n/2]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值