POJ_2395_Out of Hay【基础最小生成树】

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description
The cows have run out of hay, a horrible event that must be remedied immediately.
 Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000)
  farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M
  (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms.
   Some farms may be multiply connected with different length roads. All farms are connected one way
    or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of
 water for each unit of length of a road. Since she can get more water at each farm, she's only
 concerned about the length of the longest road. Of course, she plans her route between farms such
  that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of
 longest road she'll have to travel between any two farms, presuming she chooses routes that minimize
  that number? This means, of course, that she might backtrack over a road in order to minimize the
   length of the longest road she'll have to traverse.

Input
* Line 1: Two space-separated integers, N and M.

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a
road from A_i to B_i of length L_i.

Output
* Line 1: A single integer that is the length of the longest road required to be traversed.

Sample Input

3 3
1 2 23
2 3 1000
1 3 43

Sample Output

43


#include <stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
int map[2001][2001];
int used[2001];
int dist[2001];
int n,m;
int sum;
int max;
void init()
{
	memset(used,0,sizeof(used));
	memset(dist,inf,sizeof(dist));
}
void Prim()
{
	init();
	int i;
	dist[1] = 0;
	while(1)
	{
		int u = -1,v,i,min = inf;
		for(i=1;i<=n;i++)
		{
			if(min>dist[i] && !used[i])
			{
				min = dist[i];
				u = i;
			}
		}
		if(u==-1)
		{
			break;
		}
		used[u] = 1;
		for(v=1;v<=n;v++)
		{
			if(map[u][v]!=inf && !used[v] && dist[v]>map[u][v])
			{
				dist[v] = map[u][v];
			}
		}
	}
}
int min(int a,int b)
{
	return a>b?b:a;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j;
		int x,y,z;
		memset(map,0x3f,sizeof(map));
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%d",&x,&y,&z);
			map[x][y] = map[y][x] = min(z,map[x][y]);
		}
		Prim();	
		printf("%d\n",max);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值