HDU 2114 Calculate S(n)(数学题)(数学公式)1^3+2^3+3^3+……+(n-1)^3+n^3=n^2(n+1)^2/4

Calculate S(n)

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10014    Accepted Submission(s): 3628


Problem Description
Calculate S(n).

S(n)=1 3+2 3  +3 3  +......+n 3  .
 

Input
Each line will contain one integer N(1 < n < 1000000000). Process to end of file.
 

Output
For each case, output the last four dights of S(N) in one line.
 

Sample Input
  
  
1 2
 

Sample Output
  
  
0001 0009
 

 这个题目一上手,就感觉是个卡时间复杂度的题目,而且是数学题奥!

数学公式://1^3+2^3+3^3+……+(n-1)^3+n^3=n^2(n+1)^2/4

另外附://1^2+2^2+3^2+4^2+5^2………………+n^2=n(n+1)(2n+1)/6

但是,用数学公式如果不小心(like me),肯定会wa掉N次,因为要尽量把平方那一步放到最后,才可以尽量简化运算,然后ac。

注意:格式,要用long long或者__int64否则会爆内存。

第一种:

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    __int64 n;
    while(~scanf("%I64d",&n))//1^3+2^3+3^3+……+(n-1)^3+n^3=n^2(n+1)^2/4
    {//1^2+2^2+3^2+4^2+5^2………………+n^2=n(n+1)(2n+1)/6
        __int64 ans;
        ans=n%10000;
        ans=ans*(n+1)%10000;
        ans/=2;
        printf("%04I64d\n",ans*ans%10000);
    }
    return 0;
}

第二种:

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    long long n;
    while(~scanf("%lld",&n))//1^3+2^3+3^3+……+(n-1)^3+n^3=n^2(n+1)^2/4
    {//1^2+2^2+3^2+4^2+5^2………………+n^2=n(n+1)(2n+1)/6
        long long ans;
        ans=n%10000*(n+1)%10000/2;
        ans=ans*ans%10000;
        printf("%04lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值