Sightseeing tour

15 篇文章 0 订阅
3 篇文章 0 订阅

Sightseeing tour
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8276 Accepted: 3489

Description
The city executive board in Lund wants to construct a sightseeing tour by bus in Lund, so that tourists can see every corner of the beautiful city. They want to construct the tour so that every street in the city is visited exactly once. The bus should also start and end at the same junction. As in any city, the streets are either one-way or two-way, traffic rules that must be obeyed by the tour bus. Help the executive board and determine if it’s possible to construct a sightseeing tour under these constraints.

Input
On the first line of the input is a single positive integer n, telling the number of test scenarios to follow. Each scenario begins with a line containing two positive integers m and s, 1 <= m <= 200,1 <= s <= 1000 being the number of junctions and streets, respectively. The following s lines contain the streets. Each street is described with three integers, xi, yi, and di, 1 <= xi,yi <= m, 0 <= di <= 1, where xi and yi are the junctions connected by a street. If di=1, then the street is a one-way street (going from xi to yi), otherwise it’s a two-way street. You may assume that there exists a junction from where all other junctions can be reached.

Output
For each scenario, output one line containing the text “possible” or “impossible”, whether or not it’s possible to construct a sightseeing tour.

Sample Input

4
5 8
2 1 0
1 3 0
4 1 1
1 5 0
5 4 1
3 4 0
4 2 1
2 2 0
4 4
1 2 1
2 3 0
3 4 0
1 4 1
3 3
1 2 0
2 3 0
3 2 0
3 4
1 2 0
2 3 1
1 2 0
3 2 0

Sample Output

possible
impossible
impossible
possible

Source
Northwestern Europe 2003
混合欧拉图

参考下面的解释:

【混合图】
混合图(既有有向边又有无向边的图)中欧拉环、欧拉路径的判定需要借助网络流!

(1)欧拉环的判定:
一开始当然是判断原图的基图是否连通,若不连通则一定不存在欧拉环或欧拉路径(不考虑度数为0的点)。

其实,难点在于图中的无向边,需要对所有的无向边定向(指定一个方向,使之变为有向边),使整个图变成一个有向欧拉图(或有向半欧拉图)。若存在一个定向满足此条件,则原图是欧拉图(或半欧拉图)否则不是。关键就是如何定向?

首先给原图中的每条无向边随便指定一个方向(称为初始定向),将原图改为有向图G’,然后的任务就是改变G’中某些边的方向(当然是无向边转化来的,原混合图中的有向边不能动)使其满足每个点的入度等于出度。
设D[i]为G’中(点i的出度 - 点i的入度)。可以发现,在改变G’中边的方向的过程中,任何点的D值的奇偶性都不会发生改变(设将边i,j>改为j, i>,则i入度加1出度减1,j入度减1出度加1,两者之差加2或减2,奇偶性不变)!而最终要求的是每个点的入度等于出度,即每个点的D值都为0,是偶数,故可得:若初始定向得到的G’中任意一个点的D值是奇数,那么原图中一定不存在欧拉环!

若初始D值都是偶数,则将G’改装成网络:设立源点S和汇点T,对于每个D[i]>0的点i,连边S, i>,容量为D[i]/2;对于每个D[j]<0的点j,连边j, T>,容量为-D[j]/2;G’中的每条边在网络中仍保留,容量为1(表示该边最多只能被改变方向一次)。求这个网络的最大流,若S引出的所有边均满流,则原混合图是欧拉图,将网络中所有流量为1的中间边(就是不与S或T关联的边)在G’中改变方向,形成的新图G”一定是有向欧拉图;若S引出的边中有的没有满流,则原混合图不是欧拉图。

为什么能这样建图?
考虑网络中的一条增广路径S–>i–>…–>j–>T,将这条从i到j的路径在G’中全部反向,则:i的入度加1出度减1,j的入度减1出度加1,路径中其它点的入度出度均不变。而i是和S相连的,因此初始D[i]>0,即i的出度大于入度,故这样反向之后D[i]减少2;同理,j是和T相连的,这样反向之后D[j]增加2。因此,若最大流中边S, i>满流(流量为初始D[i]/2),此时D[i]值就变成了0,也就是i的入度等于出度。因此只要使所有S引出的边全部满流,所有初始D值>0的点的D值将等于0,又因为将边变向后所有点的D值之和不变,所有初始D值小于0的点的D值也将等于0,而初始D值等于0的D点既不与S相连也不与T相连,所以它们是网络中的中间点,而中间点的流入量等于流出量,故它们的入度和出度一直不变,即D值一直为0。因此,整个图G’成为欧拉图。
(2)欧拉路径的判定:
首先可以想到的是枚举欧拉路径的起点i和终点j,然后在图中添加边j, i>,再求图中是否有欧拉回路即可。但是,该算法的时间复杂度达到了O(M * 最大流的时间),需要优化。
前面已经说过,在将边变向的过程中任何点的D值的奇偶性都不会改变,而一个有向图有欧拉路径的充要条件是基图连通且有且只有一个点的入度比出度少1(作为欧拉路径的起点),有且只有一个点的入度比出度多1(作为终点),其余点的入度等于出度。这就说明,先把图中的无向边随便定向,然后求每个点的D值,若有且只有两个点的初始D值为奇数,其余的点初始D值都为偶数,则有可能存在欧拉路径(否则不可能存在)。进一步,检查这两个初始D值为奇数的点,设为点i和点j,若有D[i]>0且D[j]<0,则i作起点j作终点(否则若D[i]与D[j]同号则不存在欧拉路径),连边j, i>,求是否存在欧拉环即可(将求出的欧拉环中删去边j, i>即可)。这样只需求一次最大流。
就是转化成最大流,最一次最大流,看是不是满流

#include <map>
#include <list>
#include <cmath>
#include <queue>
#include <stack>
#include <string>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define LL long long
#define PI acos(-1.0)
#define MMM 0x3f3f3f3f
#define RR freopen("input.txt","r",stdin)
#define WW freopen("output.txt","w",stdout)

const int INF = 0x3f3f3f3f;

const int Max=250;

struct node
{
    int v;
    int cap;
    int next;
}Edge[Max*100];

int top;

int Head[Max];

int sign[Max];

int n,m;

int out[Max],in[Max];

void AddEdge(int u,int v,int w)
{
    Edge[top].v=v;Edge[top].cap=w;
    Edge[top].next=Head[u];
    Head[u]=top++;
    Edge[top].v=u;Edge[top].cap=0;
    Edge[top].next=Head[v];
    Head[v]=top++;
}

bool bfs()
{
    memset(sign,0,sizeof(sign));
    queue<int >Q;
    Q.push(0);
    sign[0]=1;
    while(!Q.empty())
    {
        int a=Q.front();
        Q.pop();
        for(int i=Head[a];i!=-1;i=Edge[i].next)
        {
            if(sign[Edge[i].v]==0&&Edge[i].cap>0)
            {
                sign[Edge[i].v]=sign[a]+1;
                Q.push(Edge[i].v);
            }
        }
    }
    return sign[n+1];
}
int dfs(int star,int num)
{
    if(star==n+1||num==0)
    {
        return num;
    }
    int s=0;
    int ant;
    for(int i=Head[star];i!=-1;i=Edge[i].next)
    {
        if(sign[star]+1==sign[Edge[i].v]&&(ant=dfs(Edge[i].v,min(num,Edge[i].cap)))>0)
        {
            Edge[i].cap-=ant;
            Edge[i^1].cap+=ant;
            s+=ant;
            num-=ant;
            if(num==0)
            {
                break;
            }
        }
    }
    return s;
}
int Dinic()
{
    int ant=0;
    while(bfs())
    {
        ant+=dfs(0,INF);
    }
    return ant;
}
int main()
{
    int T;
    int sum;
    int u,v,w;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d %d",&n,&m);
        memset(out,0,sizeof(out));
        memset(in,0,sizeof(in));
        memset(Head,-1,sizeof(Head));
        top=0;
        sum=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            out[u]++;
            in[v]++;
            if(w==0)
            {
                AddEdge(u,v,1);
            }
        }
        bool flag=false;
        for(int i=1;i<=n;i++)
        {
            if(out[i]-in[i]>0)
            {
                AddEdge(0,i,(out[i]-in[i])/2);
            }
            else if(in[i]-out[i]>0)
            {
                AddEdge(i,n+1,(in[i]-out[i])/2);
                sum+=(in[i]-out[i])/2;
            }

            if((out[i]-in[i])&1)
            {
                flag=true;
                break;
            }
        }
        if(flag)
        {
            printf("impossible\n");
            continue;
        }
        else
        {
            if(sum==Dinic())
            {
                printf("possible\n");
            }
            else
            {
                printf("impossible\n");
            }
        }

    }
    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值