Monthly Expense(二分查找)

Monthly Expense
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17982 Accepted: 7190

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input
Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source
USACO 2007 March Silver

#include <set>
#include <map>
#include <list>
#include <stack>
#include <cmath>
#include <queue>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#define PI cos(-1.0)
#define RR freopen("input.txt","r",stdin)

using namespace std;

typedef long long LL;

const int MAX=100010;

int n,m;

int a[MAX];

bool Judge(int s)//二分查找
{
    int sum=0;
    int ans=1;
    for(int i=1;i<=n;i++)
    {
        if(sum+a[i]<=s)
        {
            sum+=a[i];
        }
        else
        {
            sum=a[i];
            ans++;
        }
        if(ans>m)
        {
            return false;
        }
    }

    if(ans<=m)
    {
        return true;
    }
    else
    {
        return false;
    }
}
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        int L=0,R=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            R+=a[i];
            L=max(L,a[i]);
        }
        int ans=R;
        while(L<=R)
        {
            int mid=(L+R)>>1;
            if(Judge(mid))
            {
                R=mid-1;
                ans=mid;
            }
            else
            {
                L=mid+1;
            }
        }
        cout<<ans<<endl;
    }
    return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值