关闭

Pillow依赖库安装

标签: pythonpillow
1981人阅读 评论(1) 收藏 举报
分类:

Pillow库链接:https://pypi.python.org/pypi/Pillow

ubuntu安装依赖:

sudo apt-get install libtiff5-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

centos安装依赖:

yum install zlib zlib-devel
yum install libjpeg libjpeg-devel
yum install freetype freetype-devel
(ubuntu的依赖库安装我测试过,是可行的;centos的安装是朋友提供的,我没测试过,不过应该可行的。)

安装完相应系统的依赖库,就可以安装Pillow了。

我这边习惯离线安装,Pillow官方的链接下载太慢了,由于部分原因机子无法改用国内源,所以去官网下载离线文件Pillow-3.0.0.tar.gz ,接着就是安装了:

pip install Pillow-3.0.0.tar.gz

大功告成~

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:46872次
    • 积分:820
    • 等级:
    • 排名:千里之外
    • 原创:34篇
    • 转载:16篇
    • 译文:0篇
    • 评论:1条
    文章分类
    最新评论