HDU 1045&ZOJ 1002 Fire Net (还是DFS呀...)

153 篇文章 0 订阅
29 篇文章 0 订阅


Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9172    Accepted Submission(s): 5341


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.  

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.  

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.  

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.  

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.  



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.  
 


Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.  
 


Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 


Sample Input
  
  
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 


Sample Output
  
  
5 1 5 2 4
 


Source

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1045

题意:有一个n*n的广场,' . '代表空地,' # '代表墙,问用碉堡射击,最多需要多少个碉堡,同一行或列不能有超过一个的碉堡,除非中间有墙.
还是深搜呀...

AC代码:(用‘1’标记放过的地方)

#include <cstdio>
char a[5][5];
int n,maxa;
bool OK(int x,int y)
{
    for(int i=x-1; i>=0; i--)
    {
        if(a[i][y]=='1')
            return false;
        if(a[i][y]=='X')
            break;
    }
    for(int i=y-1; i>=0; i--)
    {
        if(a[x][i]=='1')
            return false;
        if(a[x][i]=='X')
            break;
    }
    return true;
}
void DFS(int x,int ans)//搜索位置,当前结果
{
    if(x==n*n)
    {
        if(ans>maxa)
            maxa=ans;
        return;
    }
    int xi=x/n;
    int yi=x%n;
    if(a[xi][yi]=='.'&&OK(xi,yi))
    {
        a[xi][yi]='1';
        DFS(x+1,ans+1);
        a[xi][yi]='.';
    }
    DFS(x+1,ans);//如果这一点是墙或者不合法,
                 //搜索下一个点,枪数不变
}
int main()
{
    while(scanf("%d",&n)!=EOF,n)
    {
        for(int i=0; i<n; i++)
            scanf("%s",a[i]);
        maxa=0;
        DFS(0,0);
        printf("%d\n",maxa);
    }
    return 0;
}

AC代码2:(用vis[][]标记)

#include <iostream>
#include <cstring>
using namespace std;
int n,m,t;
int ex,ey;
bool flag;
char a[10][10];
bool vis[10][10];
int dir[4][2]= {0,1,0,-1,1,0,-1,0};
bool OK(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m)
        return false;
    return true;
}
int abs(int x)
{
    return x<0?-x:x;
}
void DFS(int x,int y,int tx)
{
    //cout<<"x="<<x<<",y="<<y<<",tx="<<tx<<endl;
    if(x==ex&&y==ey&&tx==t)
    {
        flag=true;
        return;
    }
    if(flag) return ;
    int tt=t-tx-(abs(x-ex)+abs(y-ey));
    if(tt<0||tt&1)
        return;
    for(int i=0; i<4; i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(OK(xx,yy)&&!vis[xx][yy]&&a[xx][yy]!='X')
        {
            vis[xx][yy]=true;
            DFS(xx,yy,tx+1);
            vis[xx][yy]=false;
        }
    }
}
int main()
{
    while(cin>>n>>m>>t,n,m,t)
    {
        for(int i=0; i<n; i++)
            cin>>a[i];
        int x=0;
        int sx,sy;
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                if(a[i][j]=='S')
                    sx=i,sy=j;
                else if(a[i][j]=='X')
                    x++;
                else if(a[i][j]=='D')
                    ex=i,ey=j;
            }
        }
        if(m*n-x<=t)
        {
            cout<<"NO"<<endl;
            continue;
        }
        memset(vis,false,sizeof(vis));
        vis[sx][sy]=true;
        flag=false;
        DFS(sx,sy,0);
        if(flag)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值