XTOJ 1245 Hamiltonian Path【伪最短路,水题】

Hamiltonian Path

Accepted : 41 Submit : 96
Time Limit : 2000 MS Memory Limit : 65536 KB

Hamiltonian Path

In ICPCCamp, there are  n  cities and  m  directed roads between cities. The  i -th road going from the  ai -th city to the  bi -th city is  ci  kilometers long. For each pair of cities  (u,v) , there can be more than one roads from  u  to  v .

Bobo wants to make big news by solving the famous Hamiltonian Path problem. That is, he would like to visit all the  n  cities one by one so that the total distance travelled is minimized.

Formally, Bobo likes to find  n  distinct integers  p1,p2,,pn  to minimize  w(p1,p2)+w(p2,p3)++w(pn1,pn)  where  w(x,y)  is the length of road from the  x -th city to the  y -th city.

Input

The input contains at most  30  sets. For each set:

The first line contains  2  integers  n,m  ( 2n105,0m105 ).

The  i -th of the following  m  lines contains  3  integers  ai,bi,ci  ( 1ai<bin,1ci104 ).

Output

For each set, an integer denotes the minimum total distance. If there exists no plan, output -1 instead.

Sample Input

3 3
1 2 1
1 3 1
2 3 1
3 2
1 2 1
1 3 2

Sample Output

2
-1

原题链接:http://202.197.224.59/OnlineJudge2/index.php/Problem/read/id/1245

水题:有n个城市,问按顺序从1到n的最短路径。

AC代码:

/**
  * 行有余力,则来刷题!
  * 博客链接:http://blog.csdn.net/hurmishine
  *
*/

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=1e5;
const int INF=1e9;
int a[maxn];
int main()
{
    //freopen("data.txt","r",stdin);
    int n,m;
    while(cin>>n>>m)
    {
        for(int i=2;i<=n;i++)
            a[i]=INF;
        int x,y,z;
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(y-x==1&&z<a[y])
            {
                a[y]=z;
            }
        }
        bool flag=true;
        int ans=0;
        for(int i=2;i<=n;i++)
        {
            if(a[i]<INF)
                ans+=a[i];
            else
            {
                flag=false;
                break;
            }
        }
        if(flag)
            cout<<ans<<endl;
        else
            cout<<"-1"<<endl;
    }
    return 0;
}

尊重原创,转载请注明出处: http://blog.csdn.net/hurmishine


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值