POJ 1365(质因数分级+素数打表)



Prime Land

                                     Time Limit: 1000ms                                Memory Limit: 10000KB


Everybody in the Prime Land is using a prime base number system. In this system, each positive integer x is represented as follows: Let {pi}i=0,1,2,... denote the increasing sequence of all prime numbers. We know that x > 1 can be represented in only one way in the form of product of powers of prime factors. This implies that there is an integer kx and uniquely determined integers e kx, e kx-1, ..., e 1, e 0, (e kx > 0), that   The sequence 

(e kx, e kx-1, ... ,e 1, e 0



is considered to be the representation of x in prime base number system. 

It is really true that all numerical calculations in prime base number system can seem to us a little bit unusual, or even hard. In fact, the children in Prime Land learn to add to subtract numbers several years. On the other hand, multiplication and division is very simple. 

Recently, somebody has returned from a holiday in the Computer Land where small smart things called computers have been used. It has turned out that they could be used to make addition and subtraction in prime base number system much easier. It has been decided to make an experiment and let a computer to do the operation ``minus one''. 

Help people in the Prime Land and write a corresponding program. 

For practical reasons we will write here the prime base representation as a sequence of such pi and ei from the prime base representation above for which ei > 0. We will keep decreasing order with regard to pi. 

Input

The input consists of lines (at least one) each of which except the last contains prime base representation of just one positive integer greater than 2 and less or equal 32767. All numbers in the line are separated by one space. The last line contains number 0.

Output

The output contains one line for each but the last line of the input. If x is a positive integer contained in a line of the input, the line in the output will contain x - 1 in prime base representation. All numbers in the line are separated by one space. There is no line in the output corresponding to the last ``null'' line of the input.

Sample Input

17 1
5 1 2 1
509 1 59 1
0

Sample Output

2 4
3 2
13 1 11 1 7 1 5 1 3 1 2 1

题目大意(质因数分解+素数打表):给出n的质因数分解式,求n-1的质因数的分解式。比如第二组sample,就是5^1*2^1=10, 求10-1即9的质因数分解,从大到小输出。


代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>

using namespace std;

const int maxn = 100002;

bool isPrime[maxn];
int total,prime[maxn];
int path[maxn];//底
int po[maxn];//指数
int cnt;//用到了多少个质因数

void dabiao(){//欧拉筛选法产生素数表
    total=0;
    memset(isPrime,true,sizeof(isPrime));
    for(int i=2;i<=maxn;i++){
        if(isPrime[i]){
            prime[total++]=i;
        }
        for(int j=0;j<=total;j++){
            if(i*prime[j]>maxn) break;
            isPrime[i*prime[j]]=false;
            if(i%prime[j] == 0) break;
        }
    }
}

void solve(int n){//对n进行质因数分解
    cnt=0;
    for(int i=0;prime[i]<=n&&n!=1;i++){
        int ct=0;
        while(n%prime[i]==0){
            ct++;
            n/=prime[i];
        }
        if(ct!=0){
            path[cnt] = prime[i];
            po[cnt++] = ct;
        }
    }
    for(int i=cnt-1;i>=0;i--){//输出分解完的式子
        if(i!=0)printf("%d %d ",path[i],po[i]);
        else printf("%d %d\n",path[i],po[i]);
    }
}

int main(){
    dabiao();
    int a,b,num;
    char ch;
    while(~scanf("%d",&a)&&a){//注意这种格式输入的处理
        scanf("%d%c",&b,&ch);
        num=1;
        num*=(int)pow(a*1.0,b*1.0);
        while(ch!='\n'){
            scanf("%d%d%c",&a,&b,&ch);
            num*=pow(a+0.0,b);//这里一定要写成这个形式,不知道为什么,求解答
        }
        solve(num-1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值