HDU5935+(思路)+2016年中国大学生程序设计竞赛(杭州)



Car

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1487    Accepted Submission(s): 428


Problem Description
Ruins is driving a car to participating in a programming contest. As on a very tight schedule, he will drive the car without any slow down, so the speed of the car is non-decrease real number.

Of course, his speeding caught the attention of the traffic police. Police record  N  positions of Ruins without time mark, the only thing they know is every position is recorded at an integer time point and Ruins started at  0 .

Now they want to know the  minimum time that Ruins used to pass the last position.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case begins with an integers  N , which is the number of the recorded positions.

The second line contains  N  numbers  a1 a2 aN , indicating the recorded positions.

Limits
1T100
1N105
0<ai109
ai<ai+1
 

Output
For every test case, you should output  'Case #x: y', where  x indicates the case number and counts from  1 and  y is the minimum time.
 

Sample Input
      
      
1 3 6 11 21
 

Sample Output
      
      
Case #1: 4
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6032  6031  6030  6029  6028 




题意
一辆车开始行驶,速度不会减慢;给出两点之间的距离, 每一次记录的花费时间都是整数,让你求出最小时间花费
思路
由于速度不会减小,且花费时间都是整数,则倒着来
最后两点之间的速度最大,且时间最小,v=a[n]-a[n-1];
这之前的速度<=之后的速度
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
    int t,T=1;
    int n;
    int a[100005];
    scanf("%d",&t);
    while(t--)
    {
        double v,mm;
        int m,sum;
        scanf("%d",&n);
        a[0]=0;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        m=a[n]-a[n-1];
        v=m*1.0;
        sum=1;
        for(int i=n-1;i>0;i--)
        {
            //cout<<v<<endl;
            for(int j=(a[i]-a[i-1])/v;;j++)//时间逐渐增大,求出最大速度
            {
                double mm=(a[i]-a[i-1])*1.0/j;
               // cout<<j<<" "<<v<<endl;
                if(mm<=v)
                {
                    sum+=j;
                    v=mm;
                    break;
                }
            }
        }
        printf("Case #%d: %d\n",T++,sum);
    }
}



 

Car

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1487    Accepted Submission(s): 428


Problem Description
Ruins is driving a car to participating in a programming contest. As on a very tight schedule, he will drive the car without any slow down, so the speed of the car is non-decrease real number.

Of course, his speeding caught the attention of the traffic police. Police record  N  positions of Ruins without time mark, the only thing they know is every position is recorded at an integer time point and Ruins started at  0 .

Now they want to know the  minimum time that Ruins used to pass the last position.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case begins with an integers  N , which is the number of the recorded positions.

The second line contains  N  numbers  a1 a2 aN , indicating the recorded positions.

Limits
1T100
1N105
0<ai109
ai<ai+1
 

Output
For every test case, you should output  'Case #x: y', where  x indicates the case number and counts from  1 and  y is the minimum time.
 

Sample Input
       
       
1 3 6 11 21
 

Sample Output
       
       
Case #1: 4
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6032  6031  6030  6029  6028 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值