(3) J2SE 5.0 的 JAVA_HOME 配置问题

原创 2005年02月28日 11:06:00
这个问题已经困挠我好些天了,一直想不通怎么一回事。我用的操作系统是Windows 2000 Professional.
我机器上原本安装着 j2sdk1.4.2_07,在系统变量里面设置了
JAVA_HOME = c:/Program Files/JAVA/j2sdk1.4.2_07
Path = c:/Program Files/JAVA/j2sdk1.4.2_07
在 cmd 中 java -version,一切正常告诉我是 J2SDK 1.4.2_07

奇怪的事情是在安装 jdk1.5.0_01 的时候发生的,装完以后,没有配置任何的JAVA_HOME参数和Path参数。
在 cmd 中 java -version,告诉我了现在的版本是 j2sdk1.5.0_01。
开始以为它想Oracle一样在系统变量中自动添加了相关的Path等参数,不过我仔细的找了一遍没有发现。

我想系统中的默认 JAVA_HOME 还是用 j2sdk1.4.2,j2sdk1.5.0 只是想在 Eclipse 3.1M4 中做一些测试而已,我应该怎么配置呢?!

有人碰到过这种问题吗?!



下定决心,不怕牺牲,排除万难,争取胜利

My productivity Workstation (转自http://kgionline.com)
作者 Re:J2SE 5.0 的 JAVA_HOME 配置问题,郁闷了 [Re:jianhua23]
PrimeJava

我思故我在



发贴: 110
积分: 13
于 2005-02-25 15:46 user profilesend a private message to userreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
http://www.cjsdn.net/post/view?bid=1&id=128247&sty=1&tpg=1&age=0

不知道对你有没有帮助。



欲做精金美玉的人品,定从烈火中煅来;
思立掀天揭地的事功,需向薄冰上履过。

天将降大任与斯人也,必先苦其心志,劳其筋骨,饿其体肤,空乏其身,行拂乱其所为,所以动心忍性,增益其所不能。

We grow neither better nor worse as we grow old but more like ourselves.

学习SWT最好的资源
作者 Re:J2SE 5.0 的 JAVA_HOME 配置问题,郁闷了 [Re:jianhua23]
leowu2000



版主


发贴: 148
积分: 11
于 2005-02-25 16:12 user profilesend a private message to userreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
Path = c:/Program Files/JAVA/j2sdk1.4.2_07
???
应该加上bin。



Eclipse邮件列表

IDEA 4.5.4已经发布了。
作者 Re:J2SE 5.0 的 JAVA_HOME 配置问题,郁闷了 [Re:jianhua23]
logix

莫等闲,白了少年头



发贴: 51
积分: 0
于 2005-02-27 19:46 user profilesend a private message to usersend email to logixreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
嗯,我也有同样的困扰,公司的产品要基于1.4开发,我又想试试1.5。不过PrimeJava 提到的那篇文章写的很好,问题基本解决,可以通过改path切换。现在就是applet runtime好像还是有点问题。


作者 Re:J2SE 5.0 的 JAVA_HOME 配置问题,郁闷了 [Re:jianhua23]
jianhua23

冰冰



发贴: 68
积分: 40
于 2005-02-28 09:39 user profilesend a private message to userreply to postsearch all posts byselect and copy to clipboard. 
ie only, sorry for netscape users:-)add this post to my favorite list
Path 的那个bin是加的,前面是疏忽,没有写。
好了,基本上搞定但是还有一个小问题,我来写一下吧。
当你在安装 1.5.0 j2sdk 的时候,如果选择了 public jre 的话,他会取代掉原先的 1.4.2_07 的 public jre,你在注册表里面可以看到。
--------------------------------------------------------------------------------------
HKEY_LOCAL_MACHINE/Software/JavaSoft/Java Runtime Environment
值为 1.5
--------------------------------------------------------------------------------------
如果把它改成 1.4.2_07 的话(并把所有的相应参数都改为 1.4.2_07),会报出如下错误:
--------------------------------------------------------------------------------------
has value '1.4', but '1.5' is required
--------------------------------------------------------------------------------------
但解决方法也很简单,只安装一个 j2sdk 1.4.2_07 的 public jre,j2sdk 1.5.0_01 不安装 public jre。
部署两个 Eclipse,Eclipse 3.0.1 的 jre 路径指向 j2sdk 1.4.2_07 的 jre,Eclipse 3.1M4 的 jre 路径指向 j2sdk 1.5.0_01/jre 就万事 OK 了。
谢谢大家的帮助 Big Smile



下定决心,不怕牺牲,排除万难,争取胜利

用了Wallop后的猜想!

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

Java使用eclipse新建枚举报出, 项目“xxxxx”不是符合 J2SE 5.0 的项目。的解决办法

在eclipse新建的枚举报出 项目“XXXX”不是符合 J2SE 5.0 的项目。这样的 错误,结果可能是编译器的版本的问题,也可能是你JDK版本的 问题。解决这个问题你可以按照如下的步骤来实现: ...
  • he_min
  • he_min
  • 2015-09-02 20:44
  • 1150

J2SE 5.0 API [3] (中文版)

  • 2008-07-28 18:35
  • 7.03MB
  • 下载

J2SE_5.0_第05章_数组3.rar

  • 2012-05-06 21:27
  • 33.71MB
  • 下载

Jboss Seam3 Weld Jpa在J2SE中使用之二[配置]

这里主要说配置文件,老手可以略过。 web.xml seam2中的配置不再有效,seam3中需要用org.jboss.weld.environment.servlet.Listener ,来集成JSF...

J2SE_5.0_第06章_常用类3.rar

  • 2012-05-06 21:53
  • 37.49MB
  • 下载

J2SE配置问题—;expected错误总结

J2se的安装过程非常简单,跟安装软件一样,双击然后下一步直到最后。在这个过程中要注意的是一定要记住软件的安装路径,方便后面的查找。 第一步:在你想要的地方新建一个.txt的文本文件,保存为...

Java中文API J2SE5.0中文API

  • 2013-01-08 15:25
  • 26.44MB
  • 下载
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)