HDU2103 Family planning

Family planning

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10142    Accepted Submission(s): 2632


Problem Description
As far as we known,there are so many people in this world,expecially in china.But many people like LJ always insist on that more people more power.And he often says he will burn as much babies as he could.Unfortunatly,the president XiaoHu already found LJ's extreme mind,so he have to publish a policy to control the population from keep on growing.According the fact that there are much more men than women,and some parents are rich and well educated,so the president XiaoHu made a family planning policy:
According to every parents conditions to establish a number M which means that parents can born M children at most.But once borned a boy them can't born other babies any more.If anyone break the policy will punished for 10000RMB for the first time ,and twice for the next time.For example,if LJ only allowed to born 3 babies at most,but his first baby is a boy ,but he keep on borning another 3 babies, so he will be punished for 70000RMB(10000+20000+40000) totaly.
 

Input
The first line of the input contains an integer T(1 <= T <= 100) which means the number of test cases.In every case first input two integers M(0<=M<=30) and N(0<=N<=30),N represent the number of babies a couple borned,then in the follow line are N binary numbers,0 represent girl,and 1 represent boy.
 

Output
Foreach test case you should output the total money a couple have to pay for their babies.
 

Sample Input
  
  
2 2 5 0 0 1 1 1 2 2 0 0
 

Sample Output
  
  
70000 RMB 0 RMB
 

Source
 

本题题意为M表示一对夫妇应该生的孩子的数量,N表示实际生孩子的数量,如果第一次生的为男孩,则以后出生的孩子都要交罚款,如果在M数量内的孩子里面没有男孩,则超出M外的孩子要交罚款。由于最后结果了能会溢出,所以要进行处理。


#include <stdio.h>

int a[35];

int main(){
	int t,n,m;
	
	scanf("%d",&t);
	
	while(t --){
		scanf("%d%d",&m,&n);
		int flag = 0;
		long long sum = 0;
		
		for(int i = 0; i < n; i ++)
			scanf("%d",&a[i]);
		
		int money = 1;
		
		for(int i = 0; i < n; i ++){
			
			if(flag){
				sum += money;
				money *= 2;
			}
			
			if(a[i] && i < m)
				flag = 1;
				
			if(!flag && i >= m){
				sum += money;
				money *= 2;
			}
		}
		
		if(sum)
			printf("%lld0000 RMB\n",sum);
		else
			printf("0 RMB\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值