HDU-1162 Eddy's picture(最小生成树[Kruskal])

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
  
  
3.41

Kruskal算法就是并查集,学习的同时还能复习并查集


#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int INF=0x3f3f3f3f;
const double EPS=0.000001;

struct Edge {
    int s,e,w;
    Edge(int ss=0,int ee=0,int ww=INF):s(ss),e(ee),w(ww) {}
    bool operator < (const Edge& a) const {
        return w<a.w;
    }
}g[10005];

int x[105],y[105],par[10005],pa,pb;

int getPar(int a) {
    if(par[a]==a)
        return a;
    par[a]=getPar(par[a]);
    return par[a];
}

void Merge(int a,int b) {
    pa=getPar(a),pb=getPar(b);
    if(pa!=pb)
        par[pb]=pa;
}

int main() {
    int n,m,i,j,dx,dy,cnt;
    double xx,yy,ans;
    while(scanf("%d",&n)==1) {
        ans=m=0;
        cnt=1;
        for(i=0;i<n;++i) {
            scanf("%lf%lf",&xx,&yy);
            x[i]=int((xx+EPS)*10),y[i]=int((yy+EPS)*10);//防止产生精度问题,坐标乘以10保存为整型
            for(j=0;j<i;++j) {
                dx=x[i]-x[j],dy=y[i]-y[j];
                g[m].s=i,g[m].e=j,g[m].w=dx*dx+dy*dy;//防止产生精度问题,保存两点距离的平方
                ++m;
            }
            par[i]=i;
        }
        sort(g,g+m);
        for(i=0;cnt!=n;++i) {
            if(getPar(g[i].s)!=getPar(g[i].e)) {
                Merge(g[i].s,g[i].e);
                ++cnt;
                ans+=sqrt(double(g[i].w))/10;
            }
        }
        printf("%.2lf\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值