【杭电2083】The MAX

The MAX

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2437    Accepted Submission(s): 107


Problem Description
Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.
 

Input
Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.
 
Output
For each test case, output the biggest value of F you can find on a line.
 
Sample Input
  
  
2 1 2 0
 
Sample Output
  
  
4017
 
Source

Recommend
lcy   |   We have carefully selected several similar problems for you:   2807  2802  2804  2800  2816 
 

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
#include<stdio.h>
#include<algorithm>
using namespace std;
int main() {
    __int64 i,r,n;
    int a[120];
    while(scanf("%I64d",&n),n!=0) {
        for(i=0; i<n; i++) 
            scanf("%d",&a[i]);
        sort(a,a+n);
        r=a[n-1]*(2010-n);
        for(i=1; i<n; i++) 
            r=r+a[n-i-1];
        printf("%I64d\n",r);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值