could not build module foundation

原创 2015年07月08日 18:08:09

解决方案:

       在引用头文件开始加入#ifdef__OBJC__ 结束时加入#endif,例如


#ifndefPureStandard_PrefixHeader_pch
               

#definePureStandard_PrefixHeader_pch


               

#ifdef__OBJC__
               

#import"A.h"
               

#import"B.h"
 

              

#endif
               

#endif

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

iOS开发,导入c文件引发的Could not build module 'Foundation'问题

iOS开发,导入c文件引发的 Unknown type name 'NSString' 问题 今天看到个问题,编辑工程提示Unknown type name 'NSString',如...
  • Nigelr
  • Nigelr
  • 2016年05月11日 21:39
  • 2529

Xcode 出现Could not build module 'Foundation'错误

Xcode 出现Could not build module 'Foundation'错误

There is a problem starting qcCoInstaller.dll The specified module could not be found

一、如果在运行某软件或编译程序时提示缺少、找不到qcCoInstaller.dll等类似提示,您可将从脚本之家下载来的qcCoInstaller.dll拷贝到指定目录即可(一般是system系统目录或...

Failed to apply plugin [id 'com.android.application'] 和 Could not find com.android.tools.build:gradl

发现android studio是真的可爱啊,上一秒还没问题可以build运行,下一秒就出错。。。好,你任性,你牛逼。。 说下今天又遇到的两个问题:Failed to apply plugin ...

Unable to read the project file 'client.csproj'. Could not load file or assembly 'Microsoft.Build.En

错误详细信息:Unable to read the project file 'client.csproj'. Could not load file or assembly 'Microsoft.B...

Could not get unknown property 'ANDROID_BUILD_SDK_VERSION' 解决方法

Error:(7, 0) Could not get unknown property ‘ANDROID_BUILD_SDK_VERSION’ for project ‘:InitActivity’ ...
  • myf0908
  • myf0908
  • 2017年05月27日 13:34
  • 453

Android Studio Error:Could not find com.android.tools.build:gradle

今天更新Android Studio后打开Project,报如下错误: Error:Could not find com.android.tools.build:gradle:2.2.1. Sea...

更新Android Studio版本出现Could not find com.android.tools.build:gradle:2.2.3

如题,因为前阵子google更新了studio版本,像我这种喜欢作的人懒了一段时间还是去更新了,(其实是因为项目打包出来的apk太大了,刚好studio2.3版本支持转换WebP我不得已才更新=。=)...

使用vue时Module build failed: TypeError: this._init is not a function错误的解决方法

这个例子中Webpack的版本是2.1.0-beta.27。在这个版本中,loader不能用简写省去 -loader 的形式。...

Error: could not insert module dnw_usb.ko: Invalid module format

在fedora17下安装usb下载驱动dnw_usb.ko时出错了: ??????????????????????????????????????????????????????...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:could not build module foundation
举报原因:
原因补充:

(最多只允许输入30个字)