交换机端口安全总结

转载 2007年09月21日 09:27:00

    最常用的对端口安全的理解就是可根据MAC地址来做对网络流量的控制和管理,比如MAC地址与具体的端口绑定,限制具体端口通过的MAC地址的数量,或者在具体的端口不允许某些MAC地址的帧流量通过。稍微引申下端口安全,就是可以根据802.1X来控制网络的访问流量。

    首先谈一下MAC地址与端口绑定,以及根据MAC地址允许流量的配置。

    1.MAC地址与端口绑定,当发现主机的MAC地址与交换机上指定的MAC地址不同时 ,交换机相应的端口将down掉。当给端口指定MAC地址时,端口模式必须为access或者Trunk状态。

    3550-1#conf t

    3550-1(config)#int f0/1

    3550-1(config-if)#switchport mode access /指定端口模式。

    3550-1(config-if)#switchport port-security mac-address 00-90-F5-10-79-C1 /配置MAC地址。

    3550-1(config-if)#switchport port-security maximum 1 /限制此端口允许通过的MAC地址数为1。

    3550-1(config-if)#switchport port-security violation shutdown /当发现与上述配置不符时,端口down掉。

    2.通过MAC地址来限制端口流量,此配置允许一TRUNK口最多通过100个MAC地址,超过100时,但来自新的主机的数据帧将丢失。

    3550-1#conf t

    3550-1(config)#int f0/1

    3550-1(config-if)#switchport trunk encapsulation dot1q

    3550-1(config-if)#switchport mode trunk /配置端口模式为TRUNK。

    3550-1(config-if)#switchport port-security maximum 100 /允许此端口通过的最大MAC地址数目为100。

    3550-1(config-if)#switchport port-security violation protect /当主机MAC地址数目超过100时,交换机继续工作,但来自新的主机的数据帧将丢失。

    上面的配置根据MAC地址来允许流量,下面的配置则是根据MAC地址来拒绝流量。

    1.此配置在Catalyst交换机中只能对单播流量进行过滤,对于多播流量则无效。

    3550-1#conf t

    3550-1(config)#mac-address-table static 00-90-F5-10-79-C1 vlan 2 drop /在相应的Vlan丢弃流量。

    3550-1#conf t

    3550-1(config)#mac-address-table static 00-90-F5-10-79-C1 vlan 2 int f0/1 /在相应的接口丢弃流量。

    最后说一下802.1X的相关概念和配置。

    802.1X身份验证协议最初使用于无线网络,后来才在普通交换机和路由器等网络设备上使用。它可基于端口来对用户身份进行认证,即当用户的数据流量企图通过配置过802.1X协议的端口时,必须进行身份的验证,合法则允许其访问网络。这样的做的好处就是可以对内网的用户进行认证,并且简化配置,在一定的程度上可以取代Windows 的AD。

    配置802.1X身份验证协议,首先得全局启用AAA认证,这个和在网络边界上使用AAA认证没有太多的区别,只不过认证的协议是802.1X;其次则需要在相应的接口上启用802.1X身份验证。(建议在所有的端口上启用802.1X身份验证,并且使用radius服务器来管理用户名和密码)

    下面的配置AAA认证所使用的为本地的用户名和密码。

    3550-1#conf t

    3550-1(config)#aaa new-model /启用AAA认证。

    3550-1(config)#aaa authentication dot1x default local /全局启用802.1X协议认证,并使用本地用户名与密码。

    3550-1(config)#int range f0/1 -24

    3550-1(config-if-range)#dot1x port-control auto /在所有的接口上启用802.1X身份验证。

    后记

    通过MAC地址来控制网络的流量既可以通过上面的配置来实现,也可以通过访问控制列表来实现,比如在Cata3550上可通过700-799号的访问控制列表可实现MAC地址过滤。但是利用访问控制列表来控制流量比较麻烦,似乎用的也比较少,这里就不多介绍了。

    通过MAC地址绑定虽然在一定程度上可保证内网安全,但效果并不是很好,建议使用802.1X身份验证协议。在可控性,可管理性上802.1X都是不错的选择。

 

相关文章推荐

你了解Cisco交换机的端口安全功能吗?

【说明】以下内容摘自刚刚上市的《Cisco/H3C交换机高级配置与管理技术手册》一书。查看详细目录,可点击: http://book.360buy.com/10959197.html         ...
  • lycb_gz
  • lycb_gz
  • 2012年05月09日 09:58
  • 6289

利用二层交换机的“端口安全解”决局…

利用二层交换机的“端口安全解”决局域网中用户私自添加上网设备的方法        由于局域网中,特别是在宿舍区,员工私自添加无线路由器、交换机等网络设备以提供更多的接口,支持更多的上网设备。这种行...

cisco交换机安全之端口广播抑制

在2层交换机上做广播流量的控制 1.利用风暴控制 命令: switch(interface-if)#storm-control ? action Action to take for sto...

交换机端口安全配置

  • 2013年06月29日 13:40
  • 358KB
  • 下载

Cisco交换机端口安全

  • 2013年10月24日 00:49
  • 16KB
  • 下载

交换机端口安全 port-security配置详解

一、Port-Security概述 在部署园区网的时候,对于交换机,我们往往有如下几种特殊的需求: 限制交换机每个端口下接入主机的数量(MAC地址数量)限定交换机端口下所连...
  • xlh1991
  • xlh1991
  • 2013年10月17日 13:59
  • 2617

Cisco交换机 端口安全

  • 2008年10月18日 14:50
  • 44KB
  • 下载

使用Cisco Packet Tracer之交换机端口安全之MAC地址洪泛攻击

我们都知道,组建我们的网络,交换机是必不可少的一个设备,我们都会用它来做一些相应的配置,如划分VLAN、VTP、以及生成树这些,,但是当我们配置了这些以后呢?我们如何来保证我们局域网内的端口安全呢?这...

你最需要了解的H3C交换机端口安全模式

以下内容摘自正在全国热销的《Cisco/H3C交换机高级配置与管理技术手册》一书(畅销经典——《Cisco/H3C交换机配置与管理完全手册》(第二版)的配套姊妹篇)。目前京东网和卓越网上都有“满150...
  • lycb_gz
  • lycb_gz
  • 2012年10月19日 09:53
  • 3848

交换机端口安全

switchport mode access 端口调整为接入模式,切忌在uplink端口开启端口安全 switchport port-security 交换机端口安全的开关,无论后序命令为何,都必须先...
  • gofed
  • gofed
  • 2011年03月28日 19:33
  • 181
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:交换机端口安全总结
举报原因:
原因补充:

(最多只允许输入30个字)