unable to resolve module

原创 2016年12月14日 10:27:16

背景

这个问题是在react native android项目,在适配ios过程中,出现的一个错误。经过不断的调试,最后定位到问题出在项目引用cheerio模块。

尝试解决

出了这个问题,首先想到的是到react native github上去搜索issues。
https://github.com/facebook/react-native/issues/4968
这个issues就是搜索到的,关于‘unable to resolve module’的解决方案。但是,我按照上面很多人提到的各种方案,对我都没有解决。

这里写图片描述

提示意思是没有找到对应的module,但是,我按着那个路径去查看,文件是存在的。

解决方案

这里的解决方案不是通用的解决方案,只是针对我项目中使用到的cheerio模块。

卸载原来的cheerio模块,重新安装cheerio-without-node-native

然后将原来使用

import Cheerio from 'cheerio';

改为

import Cheerio from 'cheerio-without-node-native';

改完之后,我的问题就解决了。

虽然这不是通用的解决方案,但是,如果你遇到了类似的问题,很大部分是因为模块问题引起的,或者平台不兼容,或者确实缺少文件。

希望可以给你提供个思路方向。

版权声明:本文为博主原创文章,未经博主允许不得转载。

react-native报错-Unable to resolve module ‘react’

error: bundling failed: “Unable to resolve module react from C:\\Users\\liwd\\Desktop\\mywork\\react...

React-Native_学习笔记1: Unable to resolve module Dimensions from “...js” Invalid directory /Users/node_m

在使用第三方的组件的时候遇到如题的错误提示,原因是第三方组建中调用Dimensions 发生的错误,解决方法:修改第三方组件 “。js”文件中的代码 var screen = require('...
  • wxs0124
  • wxs0124
  • 2015年12月09日 16:29
  • 5435

React Native开发的仿美团小demo

使用React Native开发的一个仿美团首页小demo, 源码:https://github.com/lookingstars/RNMeituan 运行说明: 首先需要安装好运行Re...

在终端terminal运行ReactNative程序经常出现的问题

各种问题汇总: 1、Unable to resolve modules lodash  (这里举例lodash,这个lodash也可以是别的。意思就是缺少当前模块,所以需要安装) npm ...

ReactNative环境配置问题

问题1 - Cannot read property ‘root’ of null 详细报错信息: fs crawl TypeError: Cannot read property 'root' o...

React native 常见错误:unable to resolve module react-native-scrollable-tab-view

1.添加react-native-scrollable-tab-view,控制台输入 npm install react-native-scrollable-tab-view --save2....

react-native Requring invalid module "image! 解决办法 android

启动方式使用: react-native start --assetRoots ./android/app/src/main/res/ 替代 react-native run-android  ...
  • ISaiSai
  • ISaiSai
  • 2015年11月10日 18:29
  • 1070

《React-Native系列》8、RN如何打离线包

上一篇文章我们谈了bundle文件的加载和维护 ,以及在线包和离线包的区别,那我们今天来谈谈ReactNative如何打离线包。 我们先来看看官网怎么说的 Building your ap...

React-native 踩的坑

替换新的导航安装教程 安装完之后报错:、unable to resolve module 'react-navigation' from ...... This might be related t...
  • lhb_11
  • lhb_11
  • 2017年08月05日 12:34
  • 448

Unable to resolve module `react/lib/ReactComponentWithPureRenderMixin`

找到package.json,然后将之前的navigation的配置修改为如下的形式 "react-navigation": "git+https://github.com/react-comm...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:unable to resolve module
举报原因:
原因补充:

(最多只允许输入30个字)