Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/ma ven/cli/Maven

原创 2015年07月09日 22:06:12

安装maven 中出现如下异常:

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/ma
ven/cli/MavenCli : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
1)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(Cl
assRealm.java:401)
        at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(
SelfFirstStrategy.java:42)
        at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadCl
ass(ClassRealm.java:271)
        at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm
.java:254)
        at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm
.java:239)
        at org.codehaus.plexus.classworlds.launcher.Launcher.getMainClass(Launch
er.java:144)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Laun
cher.java:266)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.jav
a:229)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(La
uncher.java:415)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:
356)


出现如上异常 : 因为之前jdk的版本是 1.6  maven 版本是 3.3   因为maven 3.3 jdk必须是 jdk7 所以从重装jdk 即可 


版权声明:本文为博主原创文章,未经博主允许不得转载。

java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : Unsupported major.minor vers

一日换了一下MyEclipse,换成2016CI,结果从SVN上下载了一个工程后出现以下错误: Exception in thread "main" java.lang.UnsupportedCla...
  • e_wsq
  • e_wsq
  • 2016年08月03日 09:43
  • 6065

Exception in thread "main" java.lang.UnsatisfiedLinkError: ca.beq.util.win32.registry.RegistryKey.te

jRegistryKey 目前最新版本为:1.4.5 Java 使用 jRegistryKey 操作 Windows 注册表时抛出了以上问题,按照官方说的将 jRegistryKey.dll 文...
  • FOR_CHINA2012
  • FOR_CHINA2012
  • 2013年07月12日 10:34
  • 10960

java编译中出现了Exception in thread “main" java.lang.UnsupportedClassVersionError

java编译中出现了Exception in thread “main” java.lang.UnsupportedClassVersionError起因: StringBuilder不能赋值?不对...
  • qq_19427739
  • qq_19427739
  • 2016年04月08日 12:31
  • 14122

解决Exception in thread “main" java.lang.UnsupportedClassVersionError

Exception in thread “main" java.lang.UnsupportedClassVersionError 这个是典型的用高版本的JDK编译产生的class文件,用低版本的J...
  • xiaoshengfdyh
  • xiaoshengfdyh
  • 2015年06月18日 10:36
  • 3352

错误:Unsupported major.minor version 51.0(jdk版本错误)

java.lang.UnsupportedClassVersionError: org/apache/nutch/crawl/Crawl3 : Unsupported major.minor vers...
  • WitsMakeMen
  • WitsMakeMen
  • 2012年08月05日 18:02
  • 280043

解决:spark启动错误Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apach..

MacOS:Sierra 10.12.2 Spark版本:2.1.0 今天想在本地安装spark,结果按照步骤来竟然报错,问题原因spark 2.1.0需要java 7+的支持,但是Mac默认的...
  • MrLevo520
  • MrLevo520
  • 2017年03月19日 16:57
  • 3698

MAVEN的下载和安装-Unsupported major.minor version 51.0

1、下载 http://maven.apache.org/download.cgi 2、注意jdk版本提示 3、将下载的文件解压到某个目录 比如D:\apache-maven-3.3.9...
  • bestcxx
  • bestcxx
  • 2016年08月05日 11:01
  • 4642

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : U

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli : U...
  • se7en_q
  • se7en_q
  • 2015年07月18日 17:14
  • 4976

Exception in thread "main" java.lang.UnsupportedClassVersionError:

这种错误是因为jdk版本太低的问题,
  • jiary5201314
  • jiary5201314
  • 2014年07月21日 19:22
  • 1684

安装maven出现错误:Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/

按照官网步骤安装maven出现错误: localhost:~ wuna$ mvn -version Exception in thread "main" java.lang.Unsupported...
  • lalade2008
  • lalade2008
  • 2016年05月29日 23:31
  • 6289
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/ma ven/cli/Maven
举报原因:
原因补充:

(最多只允许输入30个字)