gulp 报"import gulp from 'gulp'"的错解决方案

2951人阅读 评论(0) 收藏 举报
分类:
在执行gulp serve时
gulp serve 

当前的node版本不支持es6新语法
所以需要一个编译转换器----babel

Babel是一个转换编译器,它能将ES6转换成可以在浏览器中运行的代码。


第一步:如果在package.json中增加一个

第二步:新建一个文件.babelrc

把下面这段文本添加到.babelrc文件中去

{
  "env": {
    "production": {
      "plugins": ["transform-react-constant-elements"]
    }
  }
}


第三步:查看node_modules文件夹中是带有babel文件夹,如果有就删除掉它

 

第四步:执行

npm install 


最后执行 gulp server 就可以正常启动了。希望能帮助到你。

1
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:814457次
    • 积分:10116
    • 等级:
    • 排名:第1677名
    • 原创:271篇
    • 转载:68篇
    • 译文:2篇
    • 评论:155条
    博客专栏
    最新评论