HDU 1069 Monkey and Banana (LIS)

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342

思路:

枚举方块6种摆放状态(含重复),按一边递增排序,求另一边的单调递增子序列的权值(高)之和最大。详见代码。


代码:

#include<stdio.h>
#include<algorithm>
using namespace std;

int dp[200];

struct node
{
    int a,b,c;
}data[200];

bool cmp(node x,node y)
{
    if(x.a!=y.a)return x.a>y.a;
    if(x.b!=y.b)return x.b>y.b;
    return x.c>y.c;
}

int main()
{
    int i,j,n,index,cnt=1;
    while(scanf("%d",&n),n)
    {
        index=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&data[index].a,&data[index].b,&data[index].c);
            index++;
            data[index].a=data[index-1].b, data[index].b=data[index-1].a, data[index].c=data[index-1].c, index++;
            data[index].a=data[index-2].a, data[index].b=data[index-2].c, data[index].c=data[index-2].b, index++;
            data[index].a=data[index-3].c, data[index].b=data[index-3].b, data[index].c=data[index-3].a, index++;
            data[index].a=data[index-4].b, data[index].b=data[index-4].c, data[index].c=data[index-4].a, index++;
            data[index].a=data[index-5].c, data[index].b=data[index-5].a, data[index].c=data[index-5].b, index++;
        }

        sort(data,data+index,cmp);

        n=0;
        for(i=0;i<index;i++)
        {
            dp[i]=data[i].c;
            for(j=0;j<i;j++)
            {
                if(data[j].a>data[i].a&&data[j].b>data[i].b&&dp[j]+data[i].c>dp[i])
                    dp[i]=dp[j]+data[i].c;
            }
            if(dp[i]>n)n=dp[i];
        }

        printf("Case %d: maximum height = %d\n",cnt++,n);
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值