HDU1058Humble Numbers

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25555    Accepted Submission(s): 11268


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000. 题目大意为存在这样的humble number他们的质因数仅有2,3,5,7. 首先分析,如果一个数是humble number,那么他们的质因数必定可以分解为这样的形式:2^a * 3^b * 5^c * 7^d,那么第i个humble number怎样求呢; 显然dp[i+1]要么等于之前的一个humble number dp[f1] * 2,要么等于另一个dp[f2] * 3,或dp[f3] * 5,或dp[f4] * 7;那么初始条件应为,dp[1]=1; f1=f2=f3=f4=1;那么代码中dp[i] = Min(dp[f1] * 2, dp[f2] * 3, dp[f3] * 5, dp[f4] * 7);为何要取最小的一个,因为这个递推需要从小到大递推, 由底向上递推,保证其连续性,即求出来的i,是当前应当求出来的,最小的humble number;而其中为什么又会出现f1++,f2++,f3++,f4++呢,这是由于,当由任意 一个ft,(t=1,2,3,4)求出当前dp[i]后,若要递推之后新的dp[i],显然应当更新这样的ft; 给出DP求解代码:
#include <stdio.h>
int min(int a, int b)
{
    return a > b ? b : a;
}
int Min(int a, int b, int c, int d)
{
    return min(a, min(b, min(c, d)));
}
int main()
{
    int dp[5843];
    dp[1] = 1;
    int f1, f2, f3, f4;
    f1 = f2 = f3 = f4 = 1;
    for (int i = 2; i <= 5842; i++)
    {
        dp[i] = Min(dp[f1] * 2, dp[f2] * 3, dp[f3] * 5, dp[f4] * 7);
        if (dp[i] == dp[f1] * 2)
            f1++;
        if (dp[i] == dp[f2] * 3)
            f2++;
        if (dp[i] == dp[f3] * 5)
            f3++;
        if (dp[i] == dp[f4] * 7)
            f4++;
    }
    int n;
    while (scanf("%d", &n) != EOF)
    {
        if (n == 0)
            break;
        printf("The %d", n);
        if (n % 10 == 1 && n % 100 != 11) printf("st ");
        else if (n % 10 == 2 && n % 100 != 12) printf("nd ");
        else if (n % 10 == 3 && n % 100 != 13) printf("rd ");
        else printf("th ");
        printf("humble number is %d.\n", dp[n]);
    }
    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值