poj 1308(并查集)

Is It A Tree?
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14319 Accepted: 4944

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source



题目类型:并查集

题目描述:看给定有向图,是否满足是一颗树。

题目分析:首先把有向边,看成无向边。看给定图是否连通。如果不连通肯定不是一颗树。
这样就抽象成了用并查集判断无向图的连通子图的数量问题了。
接下来,还需要判断给定的有向图是否满足,只有一个入度为0的顶点,没有入度为2的顶点。
注意空树。


代码如下:
#include <iostream>
#include <stdio.h>

#define N 100001

using namespace std;

int f[N];
bool visit[N];
int rank[N];
int r[N];


void makeSet(){
    for(int i = 1; i < N ; i++){
        f[i] = i;
        visit[i] = false;
        rank[i] = 0;
        r[i] = 0;
    }
}


int findRoot(int x){
    if( x == f[x] ){
        return x;
    } else {
        return f[x] = findRoot(f[x]);
    }
}

void merge(int a,int b){
    int ra = findRoot(a);
    int rb = findRoot(b);
    if(ra != rb){
        if(rank[ra] < rank[rb]) {
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if(rank[ra] == rank[rb]) {
                rank[ra]++;
            }
        }
    }
}


bool checkR(){
    bool zero = false;

    for(int i = 1; i < N ; i++){
        if( visit[i] && r[i] == 0) {
            if(!zero){
                zero = true;
            } else {
                return false;
            }
        }
        if(visit[i] && r[i] > 1){
            return false;
        }
    }
    return zero;
}
bool checkL(){
    int pre = -1;
    for(int i = 1; i < N ;i++){
        if(visit[i]){
            if(pre == -1){
                pre = findRoot(i);
            } else {
                if(pre != findRoot(i)) {
                    return false;
                }
            }
        }
    }
    return true;
}


int main()
{
    int u,v,c = 0;
    while( scanf("%d%d",&u,&v) , u != -1 || v != -1) {
        bool empty = false;
        makeSet();
        while( u != 0 || v != 0){
            visit[u] = true;
            visit[v] = true;
            r[v]++;
            merge(u,v);
            if(!empty){
                empty = true;
            }
            scanf("%d%d",&u,&v);
        }
        if( !empty ) {
            printf("Case %d is a tree.\n",++c);
            continue;
        }
        if(checkR() && checkL()){
            printf("Case %d is a tree.\n",++c);
        } else {
            printf("Case %d is not a tree.\n",++c);
        }
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值