hdu_4422_题意很重要

roblem Description
It’s yet another festival season in Gensokyo. Little girl Alice planned to pick mushrooms in five mountains. She brought five bags with her and used different bags to collect mushrooms from different mountains. Each bag has a capacity of 2012 grams. Alice has finished picking mushrooms in 0 ≤ n ≤ 5 mountains. In the i-th mountain, she picked 0 ≤ wi ≤ 2012 grams of mushrooms. Now she is moving forward to the remained mountains. After finishing picking mushrooms in all the five mountains, she want to bring as much mushrooms as possible home to cook a delicious soup.
Alice lives in the forest of magic. At the entry of the forest of magic, live three mischievous fairies, Sunny, Lunar and Star. On Alice’s way back home, to enter the forest, she must give them exactly three bags of mushrooms whose total weight must be of integral kilograms. If she cannot do so, she must leave all the five bags and enter the forest with no mushrooms.
Somewhere in the forest of magic near Alice’s house, lives a magician, Marisa. Marisa will steal 1 kilogram of mushrooms repeatedly from Alice until she has no more than 1 kilogram mushrooms in total. So when Alice gets home, what’s the maximum possible amount of mushrooms Alice has? Remember that our common sense doesn’t always hold in Gensokyo. People in Gensokyo believe that 1 kilogram is equal to 1024 grams.

Input
There are about 8192 test cases. Proceed to the end of file.
The first line of each test case contains an integer 0 ≤ n ≤ 5, the number of mountains where Alice has picked mushrooms. The second line contains n integers 0 ≤ wi ≤ 2012, the amount of mushrooms picked in each mountain.

Output
For each test case, output the maximum possible amount of mushrooms Alice can bring home, modulo 20121014 (this is NOT a prime).

Sample Input
1
9
4
512 512 512 512
5
100 200 300 400 500
5
208 308 508 708 1108

Sample Output
1024
1024
0
792
Hint

In the second sample, if Alice doesn’t pick any mushrooms from the 5-th mountain. She can give (512+512+0) =1024 grams of mushrooms to Sunny, Lunar and
Star. Marisa won’t steal any mushrooms from her as she has exactly 1 kilogram of mushrooms in total.
In the third sample, there are no three bags whose total weight is of integral kilograms. So Alice must leave all the five bags and enter the forest with no mushrooms.
In the last sample:
1.Giving Sunny, Lunar and Star: (208+308+508)=1024
2.Stolen by Marisa: ((708+1108)-1024)=792
题意:
一个人去采蘑菇,共有5个袋子,每个袋子最多装2012个蘑菇;
回家路中要给精灵 三袋蘑菇,要是1024 的整数倍否则要全部给他,之后还会有人偷他的蘑菇直到蘑菇数<=1024 才停手,问最后这个人会得到多回到蘑菇,告诉你前n袋蘑菇的数量
解:
123 直接1024;
后面 3,4 讨论

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,i,j,k;
    while(cin>>n)
    {
        int a[100],ans=0;
        for(i=0;i<n;i++) cin>>a[i];
        if(n<4)
            puts("1024");
        else if(n==4)
        {
            for(i=0;i<n;i++)
            {
                int tmp=0;
                for(j=0;j<n;j++)
                {
                    if(i==j) continue;
                    tmp+=a[j];
                }
                if(tmp%1024==0)
                {
                    ans=1024;break;
                }
            }
            if(ans) puts("1024");
            else
            {
                ans=0;
                for(i=0;i<n;i++)
                {
                    for(j=0;j<n;j++)
                    {
                        if(i==j) continue;
                        int tmp=a[i]+a[j];
                        while(tmp>1024) tmp-=1024;
                        ans=tmp>ans?tmp:ans;
                    }
                }
                cout<<ans<<endl;
            }
        }
        else
        {
            for(i=0;i<n;i++)
            for(j=0;j<n;j++)
            for(k=0;k<n;k++)
            {
                if(i!=j&&j!=k&&i!=k)
                {
                    int tmp=0;
                    for(int kk=0;kk<n;kk++) if(kk!=i&&kk!=j&&kk!=k) tmp+=a[kk];
                    if((a[i]+a[j]+a[k])%1024==0)
                    {
                        while(tmp>1024) tmp-=1024;
                        ans=tmp>ans?tmp:ans;
                    }
                }
            }
            cout<<ans<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值