hdu_1240_3维bfs,注意搜索坐标

Introduction

You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.


Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.


Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.


Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END


Sample Output

1 0
3 4
NO ROUTE

mean:
第一行的n代表有N*N*N的立方体;
接下俩给出每片n*n;
最后给出x,y,z 代表坐标和第几片,自己画要储存的图就很容易理解
ans
三维bfs
way 1

#include<bits/stdc++.h>
using namespace std;
const int N=21;
int n,dis[6][3]={1,0,0,0,1,0,0,0,1,-1,0,0,0,-1,0,0,0,-1};
char mp[N][N][N];
int vis[N][N][N],sx,sy,sz,ex,ey,ez;
struct node
{
    int x,y,z,tim;
};
int bfs(int x,int y ,int z)
{
   memset(vis,0,sizeof(vis));
    //vis[x][y][z]=1;
    node cur,nxt;
    cur.x=x,cur.y=y,cur.z=z,cur.tim=0;
    queue<node> q;
    q.push(cur);
    int i,j;
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        if(cur.x==ex&&cur.y==ey&&cur.z==ez)
            return cur.tim;
        for(i=0;i<6;i++)
        {
            nxt.x=cur.x+dis[i][0];
            nxt.y=cur.y+dis[i][1];
            nxt.z=cur.z+dis[i][2];
            if(nxt.x<0||nxt.x>=n
               ||nxt.y<0||nxt.y>=n
               ||nxt.z<0||nxt.z>=n
               ||vis[nxt.x][nxt.y][nxt.z]
               ||mp[nxt.x][nxt.y][nxt.z]=='X')
            continue;
            nxt.tim=cur.tim+1;
            vis[nxt.x][nxt.y][nxt.z]=1;
            q.push(nxt);
        }
    }
    return -1;
}
int main()
{
    char s[1111];
    int i,j;
    while(~scanf("%s%d",s,&n))
    {
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
            scanf("%s",mp[i][j]);
        scanf("%d%d%d%d%d%d",&sz,&sy,&sx,&ez,&ey,&ex);
        scanf("%s",s);
        int ans=bfs(sx,sy,sz);
        if(ans!= -1) cout<<n<<" "<<ans<<endl;
        else puts("NO ROUTE");
    }
}

way 2:

#include<bits/stdc++.h>
using namespace std;
const int N=21;
int n,dis[6][3]= { {1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,-1},{0,0,1} };;
char mp[N][N][N];
int vis[N][N][N],sx,sy,sz,ex,ey,ez;
struct node
{
    int x,y,z,tim;
};
int bfs(int x,int y,int z)
{
    int i,j,k;

    queue<node> q;
    node cur,nxt;
    cur.x=x;
    cur.y=y;
    cur.z=z;
    cur.tim=0;
    vis[x][y][z]=0;
    q.push(cur);
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        if(cur.x==ex&&cur.y==ey&&cur.z==ez)
            return cur.tim;
        for(i=0; i<6; i++)
        {
            nxt=cur;
            nxt.x+=dis[i][0];
            nxt.y+=dis[i][1];
            nxt.z+=dis[i][2];
            if(nxt.x<0||nxt.y<0||nxt.z<0
                    ||nxt.x>=n||nxt.y>=n||nxt.z>=n
                    ||mp[nxt.x][nxt.y][nxt.z]=='X')
                continue;
            nxt.tim++;
            if(nxt.tim<vis[nxt.x][nxt.y][nxt.z])
            {
                vis[nxt.x][nxt.y][nxt.z]=nxt.tim;
                q.push(nxt);
            }

        }
    }
    return -1;
}
int main()
{
    char s[1111];
    int i,j,k;
    while(~scanf("%s%d",s,&n))
    {
        for(i=0; i<n; i++)
            for(j=0; j<n; j++)
                scanf("%s",mp[i][j]);
        scanf("%d%d%d%d%d%d",&sz,&sy,&sx,&ez,&ey,&ex);
        scanf("%s",s);
        for(i=0; i<=n; i++)
            for(j=0; j<=n; j++)
                for(k=0; k<=n; k++)
                    vis[i][j][k]=99999;
        int ans=bfs(sx,sy,sz);
        if(ans!= -1) cout<<n<<" "<<ans<<endl;
        else puts("NO ROUTE");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值