usaco training 4.2.2 The Perfect Stall 最佳牛栏 题解

       

The Perfect Stall题解
Hal Burch

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.

Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

PROGRAM NAME: stall4

INPUT FORMAT

Line 1:One line with two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn.
Line 2..N+1:N lines, each corresponding to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

OUTPUT FORMAT

A single line with a single integer, the maximum number of milk-producing stall assignments that can be made. 

描述

农夫约翰上个星期刚刚建好了他的新牛棚,他使用了最新的挤奶技术。不幸的是,由于工程问题,每个牛栏都不一样。第一个星期,农夫约翰随便地让奶牛们进入牛栏,但是问题很快地显露出来:每头奶牛都只愿意在她们喜欢的那些牛栏中产奶。上个星期,农夫约翰刚刚收集到了奶牛们的爱好的信息(每头奶牛喜欢在哪些牛栏产奶)。一个牛栏只能容纳一头奶牛,当然,一头奶牛只能在一个牛栏中产奶。

给出奶牛们的爱好的信息,计算最大分配方案。

[编辑]格式

PROGRAM NAME: stall4

INPUT FORMAT:

(file stall4.in)

第一行 两个整数,N (0 <= N <= 200) 和 M (0 <= M <= 200) 。N 是农夫约翰的奶牛数量,M 是新牛棚的牛栏数量。

第二行到第N+1行 一共 N 行,每行对应一只奶牛。第一个数字 (Si) 是这头奶牛愿意在其中产奶的牛栏的数目 (0 <= Si <= M)。后面的 Si 个数表示这些牛栏的编号。牛栏的编号限定在区间 (1..M) 中,在同一行,一个牛栏不会被列出两次。

OUTPUT FORMAT:

(file stall4.out)

只有一行。输出一个整数,表示最多能分配到的牛栏的数量.

[编辑]SAMPLE INPUT

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2

[编辑]SAMPLE OUTPUT

4
-------------------------------------------------分割线---------------------------------------------------


周围一群大牛说是二分图的最大匹配,于是匈牙利算法应声而出。

然而我对这短小精悍的程序抱有一丝怀疑。以下为代码:

#include<iostream>
#include<cstring>
using namespace std;
int map[105][105];
int visit[105],flag[105];
int n,m;
bool dfs(int a) {
    for(int i=1;i<=n;i++) {
        if(map[a][i] && !visit[i]) {
            visit[i]=1;
            if(flag[i]==0 || dfs(flag[i])) {
                flag[i]=a;
                return true;
            }
        }
    }
    return false;
}
int main() {
    while(cin>>n>>m) {
        memset(map,0,sizeof(map));
        for(int i=1;i<=m;i++) {
            int x,y;
            cin>>x>>y;
            map[x][y]=1;
        }
        memset(flag,0,sizeof(flag));
        int result=0;
        for(int i=1;i<=n;i++) {
            memset(visit,0,sizeof(visit));
            if(dfs(i)) result++;
        }
        cout<<result<<endl;
    }
    return 0;
}

正当我再研究这神奇的算法时,LGS大神路过#$%@^&*。

在他的指导下,我学会了用网络流(呵呵,也是现学的,dinic不太会)来构建这种二分图的匹配。

     我们设左侧蓝点是牛,右侧红点是待匹配的牛栏

那么我们虚设一个源点和汇点,并且设每条边(包括和源点、汇点相连的边)的权是1.

我们从源点出发,求出去汇点的最大流,那么这个最大流一定是最佳匹配。

以下是代码:(这个网络流模板我是用bfs写的)

/*
PROG:stall4
ID:juan1973
LANG:C++
*/
#include <cstdio>
#include <algorithm>
#include <memory.h>
using namespace std;
int n,m,tot,flow,cnt,aug,v,p,q,i,j,u;
int map[505][505],queue[20005],pre[505];
int main()
{
    freopen("stall4.in","r",stdin);
    freopen("stall4.out","w",stdout);
    memset(map,0,sizeof(map));
    scanf("%ld%ld",&n,&m);
    for(i=1;i<=n;i++)
    {
            scanf("%ld",&p);
            for (j=1;j<=p;j++)
            {
              scanf("%ld",&q);
              map[i][q+n]=1;
            }    
    }
    flow=0;cnt=n+m+1;
    for (i=1;i<=n;i++) map[0][i]=1;
    for (i=n+1;i<=m+n;i++) map[i][cnt]=1;
    memset(queue,0,sizeof(queue));
    while(1)
    { 
            memset(pre,-1,sizeof(pre));
            queue[1]=0;
            for(p=1,q=1;p<=q;p++)
            {
                          u=queue[p];
                          for(v=1;v<=cnt;v++)
                          if(pre[v]<0&&map[u][v]>0)
                          {
                                      pre[v]=u;
                                      queue[++q]=v;     
                          }
                          if(pre[cnt]>=0)break;
            }
            if(pre[cnt]<0)break;
            aug=2000000000;
            for(v=cnt;v!=0;v=pre[v])aug=min(aug,map[pre[v]][v]);
            for(v=cnt;v!=0;v=pre[v])
            {
                    map[pre[v]][v]-=aug;
                    map[v][pre[v]]+=aug;
            }
            flow+=aug;
    }
    printf("%ld\n",flow);
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值