【1139】数据结构上机测试2-2:单链表操作B (逆序建表+重复元素删除)

15 篇文章 0 订阅

数据结构上机测试2-2:单链表操作B

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

输入

第一行输入元素个数n;
第二行输入n个整数。

输出

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

示例输入

10
21 30 14 55 32 63 11 30 55 30

示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
 
 
 
 
本题删除重复元素的思路:先设置一个struct node类型的tail指针节点,让tail指向head,(一)在让q指向tail,p指向tail的下一个节点。保持tail不动,让q和p依次向下寻找,若p的数值与tail的数值相同时就删除,直到p为NULL。(二)让tail向下移动一个重复(一),直到tail的下一个节点为NULL,结束循环。

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *creat(int n)//顺序建表函数
{
    int i;
    struct node *p,*head,*tail;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=0; i<n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=tail->next;
    }
    return head;
};
int operate(struct node *head,int n,int key)//关键元素删除函数
{
    struct node *p,*q;
    p=head->next;
    q=head;
    while(p!=NULL)
    {
        if(p->data==key)
        {
            q->next=p->next;
            free(p);
            p=q->next;
            n--;
        }
        else
        {
            q=p;
            p=p->next;
        }
    }
    return n;
};
void show(struct node *head)//链表的输出函数
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(p->next!=NULL)
            printf("%d ",p->data);
        else
            printf("%d\n",p->data);
        p=p->next;
    }
}
int main()
{
    int n,m,key;
    struct node *head;
    scanf("%d",&n);
    head=creat(n);
    scanf("%d",&key);
    printf("%d\n",n);
    show(head);
    m=operate(head,n,key);
    printf("%d\n",m);
    show(head);
    return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值