关闭

CentOS 5/6/7使用摘记

1631人阅读 评论(0) 收藏 举报
分类:

[问题]
[解决]


[问题] centos7 WARNING: terminal is not fully functional
[解决] export TERM=xterm

         yum install xterm


[问题]  CentOS7 和 win7 双系统引导, 先安装的win7在硬盘的前60G空间,后安装CentOS7在接下来的60G空间。
[解决] 需要在CentOS7的引导配置中添加对win7的引导。

vim /boot/grub2/grub.cfg

添加win7的引导

menuentry ‘windows 7’ {

                    set root=‘hd0, msdos1’

                    chainloader +1

}

需要注意的是set root=‘hd0, msdos1’可能需要调整,可能是set root=‘hd0, msdos0’, 根据实际做调整。


[问题] CentOS7 中查看哪些服务开机启动的,哪些是禁止启动的
[解决] [harvis@centos7 ~]$ systemctl  list-unit-files | grep enabled

          [harvis@centos7 ~]$ systemctl  list-unit-files | grep disabled


[问题] CentOS 7 Zstack 调节最小cpu数和最小内存数的地方
[解决] [harvis@centos7 zstack]$ sudo vim /var/lib/zstack/virtualenv/zstackctl/lib/python2.7/site-packages/zstackctl/ctl.py

里面

    MINIMAL_CPU_NUMBER = 2
    #MINIMAL_MEM_SIZE unit is KB, here is 6GB, in linxu, 6GB is 5946428 KB
    #Save some memory for kdump etc. The actual limitation is 5000000KB
    MINIMAL_MEM_SIZE = 1500000


[问题] server A ssh 无密码登录 server B
[解决] server A: ssh-keygen

                         ssh-copy-id -i ~/.ssh/id_rsa.pub B

                         ssh B


[问题] npm install tsc/webpack

[解答] sudo npm install -g typescript/

sudo npm install -g webpack

sudo npm install -g asar prebuild node-gyp

tsc is a compiler for converting TypeScript into plain JavaScript. NVIC_INT_CTRL


[问题] bhyve/Centos7 添加一块硬盘(块设备)

[解答]

host 中创建一块ZFS分区作为Centos7的一块硬盘
sudo zfs create -V16G -o volmode=dev zroot/AOSP
将ZFS分区分配给虚拟机Centos7, 这里用irtio-blk实现
-s 3:5,virtio-blk,/dev/zvol/zroot/AOSP \    
guest 查看新添加的硬盘
lsblk 可以看到 /dev/vdd

创建分区

sudo fdisk /dev/vdd

n

t 选择 83

对创建的分区进行格式化(创建XFS文件系统)

[harvis@centos7 ~]$ sudo mkfs.xfs /dev/vdd1

临时挂载(mount)

sudo mount -t xfs /dev/vdd1 /AOSP

sudo chown -R harvis:harvis /AOSP/

长久挂载

echo "" >> /etc/fstab


[问题] Centos7 查看块设备的 uuid
[解决] [harvis@centos7 ~]$ lsblk -o +UUID
NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT  UUID
sr0     11:0    1  564M  0 rom              2015-03-28-20-08-41-00
vda    253:0    0   16G  0 disk             
├─vda1 253:1    0  500M  0 part /boot       7ee72903-16fe-4d51-a064-ec8ea4cbe0b4

只有在分区格式化之后才有 UUID。


[问题][harvis@localhost Desktop]$ adb shell

error: insufficient permissions for device

[解答]

cat /etc/udev/rules.d/51-android.rules

# Google Inc. Nexus Device (debug)

SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="4ee2", MODE="0666", GROUP="plugdev"

sudo systemctl restart systemd-udev-trigger.service


[问题] libudev.so not found in Centos7
[解决] sudo yum install -y systemd-devel-219-30.el7_3.7.x86_64
         ls /lib64/libudev.so*


[问题] 编译gcc4.8报错: configure: error: cannot compute suffix of object files: cannot compile
[解决] # update LD_LIBRARY_PATH
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/share/cross-compiler/lib/

[问题] node.js software list

[解答]

nodejs-6.9.4-2.el7.x86_64

npm-3.10.10-1.6.9.4.2.el7.x86_64

npm install -g cnpm --registry=https://registry.npm.taobao.org

set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99")


[问题] minicom

[解答] hg clone https://alioth.debian.org/anonscm/hg/minicom/

REF: https://alioth.debian.org/scm/?group_id=30018


[问题] Centos7 MSYH font
[解决] copy msyh.tff msyhbd.tff to /usr/share/fonts/msyh

         cd /usr/share/fonts/msyh

         sudo fc-cache

         sudo fc-list | grep msyh

         export LANG=zh_CN.UTF-8

         cat chinese.txt


[问题] Centos7 mini install XFCE4
[解决] yum check-update

         yum groupinstall "X Window System"

         yum install epel-release

         yum groupinstall xfce
         systemctl isolate graphical.target ## 临时生效

         systemctl set-default graphical.target ## 长期生效,参考/etc/inittab说明



[问题] CentOS7安装中文语言包
[解决] sudo yum groupinstall chinese-support # for Centos6

          sudo yum install kde-l10n-Chinese-4.10.5-2.el7.noarch # for Centos7

[问题] CentOS7 VNC/xfreerdp setting

[解答] https://linux.cn/article-5335-1.html


[问题] centos7 libxss.so.1
[解决] yum whatprovides libXss*


[问题] CentOS7 install man manual
[解决] sudo yum install man-pages


[问题] Centos7 add a swap disk
[解决] cat /proc/swaps

fdisk /dev/vdb

n

t

82(Linux Swap / Solaris)


mkswap /dev/sdb1

swapon /dev/vdb1

cat /etc/fstab

/dev/vdb1(or UUID) swap swap defaults 0 0


[问题] centos6.8 static ip address setting
[解决]

[root@localhost network-scripts]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
HWADDR=00:A0:98:8B:32:4E
TYPE=Ethernet
UUID=f99713b2-65e3-49eb-942e-affdff7b29e0
ONBOOT=yes
NM_CONTROLLED=yes
BOOTPROTO=static
IPADDR=192.168.1.239
NETMASK=255.255.255.0
NETWORK=192.168.1.1
BROADCAST=192.168.1.255


[问题] centos6.8 change hostname
[解决]

vi /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=newHostName

[问题] how to configure grub.cfg for centos6 boot on bhyve
[解决] cat grub.cfg

set root=(hd0,msdos1)
linux  /vmlinuz-2.6.32-642.el6.x86_64 root=/dev/mapper/VolGroup-lv_root rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VolGroup/lv_swap SYSFONT=latarcyrheb-sun16 console=ttyS0 crashkernel=auto rd_LVM_LV=VolGroup/lv_root  KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM
initrd /initramfs-2.6.32-642.el6.x86_64.img
boot

参考: https://forums.freebsd.org/threads/55521/


[问题] linux kernel map 描述 linux kernel数据结构的全图
[解答] http://www.makelinux.net/kernel_map/


[问题] 在 CentOS7中安装 KVM virt-manager 替换 virtualbox/vmware,  guest 安装 windows xp 需要的 外设驱动, 下载地址
[解决]

This location, and the isos that were hosted here, are now deprecated.

virtio-win builds are now distributed in a new location with a new iso file
layout. A yum repo is also provided. More info here:

  https://fedoraproject.org/wiki/Windows_Virtio_Drivers

Links to the _new_ equivalent of the old stable/ and latest/ directories are
listed here:

  https://fedoraproject.org/wiki/Windows_Virtio_Drivers#Direct_download

If you need access to the old isos that were hosted here, there's a mirror at:

  https://fedorapeople.org/groups/virt/virtio-win/deprecated-isos/

Only use them if you need to maintain backwards compatability. No new isos
will be added here.

[问题] /lib/modules/3.10.0-513.el7.x86_64/build: No such file or directory

         安装kernel代码的方法?

[解决] sudo yum install kernel-devel-$(uname -r)


[问题] CentOS7网络开机自启动的方法
[解决] sudo vi /etc/sysconfig/network-scripts/ifcfg-enp3s0

ONBOOT=no 修改为 ONBOOT=yes


[问题] CentOS7 安装 cmake3 的方法
[解决]  sudo wget https://copr.fedorainfracloud.org/coprs/g/kdesig/cmake3_EPEL/repo/epel-7/heliocastro-cmake3_EPEL-epel-7.repo /etc/yum.repos.d/

            sudo yum install cmake3  


[问题] CentOS 7 安装QT Desinger工具的方法
[解决] sudo yum install -y qt5-designer-5.6.1-2.el7.x86_64


[问题] centos6 netinstall method
[解决] http://www.if-not-true-then-false.com/2011/centos-6-netinstall-network-installation/


[问题] CentOS7 安装 google chrome方法
[解决] http://www.tecmint.com/install-google-chrome-on-redhat-centos-fedora-linux/

[user]$ cat /etc/yum.repos.d/google-chrome.repo
[google-chrome]
name=google-chrome
baseurl=http://dl.google.com/linux/chrome/rpm/stable/x86_64
enabled=1
gpgcheck=1
gpgkey=https://dl-ssl.google.com/linux/linux_signing_key.pub



[问题] How to change the system locale on RHEL7/CentOS7 ?
[解决] https://access.redhat.com/solutions/974273

[问题] centos7开启coredump的方法
[解决] http://www.kibinlabs.com/re-enabling-core-dumps-redhat-7/


[问题] centos7 中网络故障,  systemctl status network.service查看到错误信息"Failed to start LSB: Bring up/down networking.", 网络不可用
[解决] MAC 地址丢失的缘故. 获取MAC地址的方法, 执行命令[ ip addr show]取字符串[f8:32:e4:8c:03:7f ], 构造ifcfg配置语句[HWADDR="f8:32:e4:8c:03:7f"]

            添加到网卡配置文件中, 比如/etc/sysconfig/network-scripts/ifcfg-enp3s0, 重启网络服务systemctl restart network即可.


[问题] yum源设置
[解决]

    cd /etc/yum.repos.d/

    wget http://mirrors.163.com/.help/CentOS-Base-163.repo

    yum check-update

    yum update

    注意不需要更改文件名,按步骤操作即可。后面两步其实是把系统和软件包都给更新了。直接把centos5.5升级到5.10了。

2. aliyun yum源的配置

    参考:http://mirrors.aliyun.com/help/centos

3. 安装glibc 2.11的步骤

   参考:http://hi.baidu.com/life_to_you/item/64db6dce367486dbef183b07 

               http://blog.csdn.net/duyiwuer2009/article/details/6867159

               http://blog.csdn.net/nameofhsw/article/details/12781905 

               http://www.oschina.net/code/explore/gcc-4.5.2/gcc/config/i386/cpuid.h

4. yum命令安装程序时,总是出现如下警告:

There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.

意思是有未完成的yum事务,建议先运行yum-complete-transaction命令清除。消除警告步骤如下:

# 安装 yum-complete-transaction(这是一个能发现未完成或被中断的yum事务的程序)
yum install yum-utils
# 清除yum缓存
yum clean all
# 运行 yum-complete-transaction,清理未完成事务
/usr/sbin/yum-complete-transaction --cleanup-only
运行上述命令需要root权限。yum 会把下载的软件包和header存储在cache中,而不会自动删除。可用yum clean headers清除header,yum clean packages清除下载的rpm包,yum clean all全清

5.  编辑DNS服务器IP地址

# vi /etc/resolv.conf

nameserver 8.8.8.8 #google域名服务器
nameserver 8.8.4.4 #google域名服务器

6. 更改系统时间和日期

修改日期: 
时间设定成2009年5月10日的命令如下: 
#date -s 05/10/2009 

 

修改时间: 
将系统时间设定成上午10点18分0秒的命令如下。 
#date -s 10:18:00 

 

修改时区: 
找到相应的时区文件 /usr/share/zoneinfo/Asia/Shanghai替换当前的/etc/localtime。 
修改/etc/sysconfig/clock文件的内容为: 
ZONE=”Asia/Shanghai” 
UTC=false 
ARC=false 

 

同步bios时间: 
同步BIOS时钟,强制把系统时间写入CMOS,命令如下: 
#clock -w 
 

参考:http://www.cnblogs.com/hjslovewcl/archive/2011/06/28/2314323.html

CentOS 6.5(32位)编译 安装 subversion 1.6.11
 
1.  源码包
subversion-1.6.11.tar.bz2
subversion-deps-1.6.11.tar.bz2
neon-0.29.3.tar.gz
subversion-1.6.11.tar.bz2
subversion-deps-1.6.11.tar.bz2
neon-0.29.3.tar.gz
   
2.  解压到同一个目录下面
tar xvf  subversion-1.6.11.tar.bz2
tar xvf  subversion-deps-1.6.11.tar.bz2
3.  将subversion-1.6.11/neon里面的内容全部删除掉,将neon-0.29.3.tar.gz解压进去subversion-1.6.11/neon
tar xvf neon-0.29.3.tar.gz -C subversion-1.6.11/neon
这一步若不用neon-0.29.3.tar.gz替代subversion-1.6.11/neon编译会报错,
subversion-1.6.11/subversion/libsvn_ra_neon/.libs/libsvn_ra_neon-1.so:undefined reference to `SSL_SESSION_cmp'
collect2: ld returned 1 exit status


CentOS升级Python到2.7

CentOS 6.3上安装的python版本是2.6,不能满足我运行软件的要求,所以对python进行升级。

Python的最新版本已经是3.3,但是Python3的兼容性可能还有一定的问题,所以还是升级到2.7较为保险。Python 2.7也能够满足绝大多数的软件需求了。

原以为这也就是安装个软件的事儿,在我求稳搜索一下了之后发现,也并不是那么单纯简单。

下载,解压,编译,安装,这些都是常规操作了。据说系统自带的旧版本python被严重依赖,所以不能卸载原Python,这里选择全新安装。

安装好后可以运行一下Python看看是否正常了

其他的文章提到python都是在/usr/local/bin目录里的,但是我没有找到,而是在/usr/local/python2.7/bin/里。

接下来需要创建一个链接来使系统默认python变为python2.7。

运行python查看版本

进行更改后,yum果然无法运行了。修改/usr/bin/yum文件,将第一行的

中的python改为系统原有的python版本,我的如下:

到此完毕。

转自:http://nerd-is.in/2013-03/upgrade-python/

【问题】ImportError: No module named pysqlite2

【解答】

The module is called sqlite3pysqlite2 was the module's name before it became part of the Python standard library.

You probably want to use this in your code:

import sqlite3

And the standard documentation is here: http://docs.python.org/library/sqlite3.html

edit: And just to cover all the bases:

The sqlite3 module also has a dbapi2 sub-member, but you don't need to use it directly. The sqlite3 module exposes all the dbapi2 members directly.


摘自:http://stackoverflow.com/questions/12044548/importerror-no-module-named-pysqlite2


【问题】 /usr/src/kernels/2.6.32-573.8.1.el6.x86_64/arch/x86/Makefile:81: stack protector enabled but no compiler support

【解答】因为检测到了CROSS_COMPILE有定义,去掉CROSS_COMPILE的定义即可

obj-m = call_usermodehelper.o
CROSS_COMPILE=
all:
        $(MAKE) -C /lib/modules/`uname -r`/build M=`pwd` modules
clean:
        rm -f call_usermodehelper.ko.unsigned  call_usermodehelper.mod.o  Module.symvers \
        call_usermodehelper.ko  call_usermodehelper.mod.c        call_usermodehelper.o      modules.order

 

[问题] centos7 中挂载windows格式的移动硬盘
[解决] sudo mount -t ntfs /dev/sdc1 /mnt/
      其中, /dev/sdc1用命令ls /dev/sd*查看

[问题] centos7 上安装32位libgtk-x11-2.0.so.0的命令
[解决] sudo yum install gtk2-2.24.28-8.el7.i686

[问题] add nux desktop repository in centos7
[解决] sudo rpm -Uvh http://li.nux.ro/download/nux/dextop/el6/x86_64/nux-dextop-release-0-2.el6.nux.noarch.rpm
      sudo yum update

[问题] Can't locate Switch.pm in @INC
[解决] yum install perl-Switch

[问题] centos7 打造android开发环境 TODO
[解决] http://tinylab.org/develop-android-under-centos7/

[问题] Linux Centos udev重启命令问题
[解决] root用户直接执行:start_udev # for Centos 6.5

sudo systemctl restart systemd-udev-trigger.service # for Centos 7


[问题] how to run 32bits application on 64bits OS You're on a 64-bit system, and don't have 32-bit library support installed
      /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
[解决] sudo yum install glibc.i686
      or, if that's not available on Centos-6,
      sudo yum install glibc.i386

[问题] Centos6 命令行实现自动补全
[解决] http://www.2cto.com/os/201504/394468.html

[问题] CentOS7 安装用于科学研究
[解决] http://seisman.info/linux-environment-for-seismology-research.html

[问题] centos 常用到快捷键操作列表
[解决] http://www.centoscn.com/CentOS/2013/0223/162.html

[问题] centos 安装virtualbox到方法?
[解决] http://blog.csdn.net/todd911/article/details/8198458

[问题] 安装桌面环境,##此法未验证
[解决]
1. 使用命令 runlevel 查看当前的运行级别 ,如图所示
2. 使用命令 yum grouplist | more  查看是否安装了桌面环境的组件,如图所示
3. yum groupinstall -y   "Desktop"   "Desktop Platform"   "Desktop Platform Development"  "Fonts"  "General Purpose Desktop"  "Graphical Administration Tools"  "Graphics Creation Tools"  "Input Methods"  "X Window System"  "Chinese Support [zh]" "Internet Browser"
4. 安装好了桌面环境的软件,然后再修改一下系统的启动级别 为 5

  编辑/etc/inittab文件,修改启级别为5,如下图,然后重新启动就可以进入桌面环境了。因为我这是远程环境的,只是运用了命令行,可以使用VNC进行桌面环境的远程。
5. 重启的过程中,设置一下桌面环境的几个参数就可以正常进入登陆界面了,谢谢。

[问题] 从移动硬盘安装CentOS 6,此法测试成功,用的是网络安装版本到iso文件
[解决] http://wiki.centos.org/HowTos/InstallFromUSBkey
http://wenku.baidu.com/link?url=R-JUqabn9iyvHVTNbV2R-2ggqWnfjShDAxLRy0uSXpmaoqyrbiwj-tU72olzWtvDINr-D2Czzs8OY9IOe9U4O2t0rDQqnNRVN-G2gGRc8KG

[问题] 分区设定,以64G为单位分区
[解决] http://blog.sina.com.cn/s/blog_54f30ece0101mkul.html

[问题] 网络配置
[解决] ip地址:194.169.3.47  
       广播地址:194.169.3.255  
       网络掩码:255.255.255.0
       DNS地址:223.5.5.5
       Search domain: 194.169.3.1 ##注意, 这个ip地址可以解析内网到DNS,比如rdm.ingenic.cn

[问题] 通过移动硬盘安装 CentOS 系统
[解决]
一、下载七个 CentOS-5.6-i386-bin-***.iso 文件到移动硬盘 fat32 格式相应分区根目录,并将第一个解压,取其 isolinux 放置在这个根目录。
(DVD的镜像文件大于4G,fat32 格式磁盘不接受。)
二、下载grub文件夹到移动硬盘,将其中的 grldr 和 menu.lst 复制到移动硬盘同上分区根目录。
三、修改menu.lst 文件,加上:
title CentOS Install
kernel /isolinux/vmlinuz
initrd /isolinux/initrd.img
boot
四、运行bootice.exe(这是个不错的工具)将移动硬盘的主、分区引导记录都设置为 grub4dos*** 。
五、设置 bios 移动硬盘启动。
六、开机进入 Grub 界面,选择 CentOS Install 安装。
安装过程中注意grub要选择安装在固定硬盘上,有相应选项。

[问题] centos7 使用cloner.sh编译cling导致的cpu过热异常
[解决]
[ingenic@localhost linux-amlogic]$ sudo mcelog
Hardware event. This is not a software error.
MCE 0
CPU 2 THERMAL EVENT TSC 1601cd5875c68
TIME 1456207892 Tue Feb 23 14:11:32 2016
Processor 2 heated above trip temperature. Throttling enabled.
Please check your system cooling. Performance will be impacted
STATUS 880003c3 MCGSTATUS 0
MCGCAP c09 APICID 4 SOCKETID 0
CPUID Vendor Intel Family 6 Model 60
Hardware event. This is not a software error.
MCE 1
CPU 6 THERMAL EVENT TSC 1601cd587e5de
TIME 1456207892 Tue Feb 23 14:11:32 2016
Processor 6 heated above trip temperature. Throttling enabled.
Please check your system cooling. Performance will be impacted
STATUS 880003c3 MCGSTATUS 0
MCGCAP c09 APICID 5 SOCKETID 0
CPUID Vendor Intel Family 6 Model 60
Hardware event. This is not a software error.
MCE 2
CPU 2 THERMAL EVENT TSC 1601cd5be3576
TIME 1456207892 Tue Feb 23 14:11:32 2016
Processor 2 below trip temperature. Throttling disabled
STATUS 88010282 MCGSTATUS 0
MCGCAP c09 APICID 4 SOCKETID 0
CPUID Vendor Intel Family 6 Model 60
Hardware event. This is not a software error.
MCE 3
CPU 6 THERMAL EVENT TSC 1601cd5bebd75
TIME 1456207892 Tue Feb 23 14:11:32 2016
Processor 6 below trip temperature. Throttling disabled
STATUS 88010282 MCGSTATUS 0
MCGCAP c09 APICID 5 SOCKETID 0
CPUID Vendor Intel Family 6 Model 60


[问题] CENTOS 6.3上安装kingsoft-office-9.1.0.4032-0.1.a10.i686.rpm

[解答]

1. 下载WPS的rpm安装包

kingsoft-office-9.1.0.4032-0.1.a10.i686.rpm

2. 无依赖安装

rpm -ivh kingsoft-office-9.1.0.4032-0.1.a10.i686.rpm --nodeps

注意以前安装过WPS的, 要先卸载掉.

卸载命令: rpm -e xxxxx.rpm

3. 添加依赖库文件到目录/opt/kingsoft/wps-office/office6/

不建议将库文件放到/usr/lib或者/lib里面, 那样做可能影响其它软件的正常运行.

WPS依赖的库, 放在它自己的库目录里, 这样就不会影响外面的世界了, 嘿嘿.

依赖的库文件手工复制到这里, 缺啥复制啥.

/opt/kingsoft/wps-office/office6/


[问题] centos7 install WPS

[解决] 参考:http://seisman.info/wps-office-for-centos7.html

http://kdl.cc.ksosoft.com/wps-community/download/a16/wps-office-9.1.0.4909-1.a16p1.i686.rpm

sudo yum install http://kdl.cc.ksosoft.com/wps-community/download/a15/wps-office-fonts-1.0-1.noarch.rpm


CentOS 6.5 32位下搭建android2.3.7开发环境

[问题] ld/core/base_rules.mk:162: *** frameworks/base/elemnt/JniWifi: MODULE.TARGET.SHARED_LIBRARIES.libelewifi_jni already defined by frameworks/base/towercraneserver/JniWifi. Stop.

[解答] mv ./frameworks/base/towercraneserver/JniWifi ./frameworks/base/towercraneserver/JniWifi_backup

mv ./frameworks/base/towercraneserver/JniWifi_backup/ ../

mv ./frameworks/base/towercraneserver/JniPhone/ ../



[问题] (unknown): error 3: Added class PhoneVoicePlayer to package android.media

[解答] make update-api



[问题] host C: adb <= system/core/adb/fdevent.c

host Executable: adb (out/host/linux-x86/obj/EXECUTABLES/adb_intermediates/adb)

/usr/bin/ld: cannot find -lncurses

[解答] yum install ncurses-devel



[问题] host Executable: sqlite3 (out/host/linux-x86/obj/EXECUTABLES/sqlite3_intermediates/sqlite3)

/usr/bin/ld: cannot find -lhistory

collect2: ld returned 1 exit status

make: *** [out/host/linux-x86/obj/EXECUTABLES/sqlite3_intermediates/sqlite3] Error 1

[解答] yum install readline-devel



[问题] target thumb C++: myeletest <= frameworks/base/elemnt/mytest/Mytest.cpp

frameworks/base/elemnt/mytest/Mytest.cpp: In static member function 'static const android::sp<android::IEleMonitorService>& android::MyEleTest::getMyTestService()':

frameworks/base/elemnt/mytest/Mytest.cpp:73: error: cannot allocate an object of abstract type 'android::MyEleTest::EleMonitorClient'

frameworks/base/elemnt/mytest/Mytest.h:44: note: because the following virtual functions are pure within 'android::MyEleTest::EleMonitorClient':

frameworks/base/elemnt/mytest/../../elemnt/libelecbinder/IEleMonitorClient.h:22: note:virtual void android::IEleMonitorClient::EleSendSmsReq(const char*, const char*)

frameworks/base/elemnt/mytest/../../elemnt/libelecbinder/IEleMonitorClient.h:23: note:virtual void android::IEleMonitorClient::ElePhoneCallReq(const char*)

frameworks/base/elemnt/mytest/../../elemnt/libelecbinder/IEleMonitorClient.h:24: note:virtual void android::IEleMonitorClient::ElePlayPacifyAudio(int, const char*)

frameworks/base/elemnt/mytest/Mytest.cpp: In member function 'void android::MyEleTest::start()':

frameworks/base/elemnt/mytest/Mytest.cpp:116: error: 'class android::IEleMonitorService' has no member named 'start'

make: *** [out/target/product/generic/obj/EXECUTABLES/myeletest_intermediates/Mytest.o] Error 1

[解答] using /* */ comment which caused compile bug #doesn't work

mv frameworks/base/elemnt/mytest/ ../



[问题] Lex: libedify <= bootable/recovery/edify/lexer.l

/bin/bash: flex: command not found

[解答] yum install flex.i686



[问题] sh: gperf: command not found

[解答] yum install gperf



[问题] ./system/core/include/arch/linux-arm/AndroidConfig.h:114:1: warning: this is the location of the previous definition

external/rp-pppoe-3.10/src/if.c:34:26: error: net/ethernet.h: No such file or directory

make: *** [out/target/product/generic/obj/EXECUTABLES/pppoe_intermediates/src/if.o] Error 1

[解答] vi external/rp-pppoe-3.10/src/config.h

#define HAVE_NET_ETHERNET_H 1 ---> /* #define HAVE_NET_ETHERNET_H 1 */



[问题] target thumb C: libaltustd-ril <= hardware/ril/altustd-ril/icc.c

make: *** No rule to make target `out/target/product/generic/obj/lib/libasound.so', needed by `out/target/product/generic/obj/SHARED_LIBRARIES/libaltustd-ril_intermediates/LINKED/libaltustd-ril.so'. Stop.

[解答] cp ./out/target/product/sam9g45/system/lib/libasound.so out/target/product/generic/obj/lib



<RESULT>Target system fs image: out/target/product/generic/obj/PACKAGING/systemimage_intermediates/system.img

Install system fs image: out/target/product/generic/system.img

Target ram disk: out/target/product/generic/ramdisk.img

Target userdata fs image: out/target/product/generic/userdata.img

Installed file list: out/target/product/generic/installed-files.txt


[问题] The repository located at mirrors.aliyun.com is not a trusted or secure host and is being ignored. If this repository is available via HTTPS it is recommended to use HTTPS instead, otherwise you may silence this warning and allow it anyways with '--trusted-host mirrors.aliyun.com'.

[解决] 新的pip要求源必须是https, mirrors.aliyun.com is not https

cat ~/.pip/pip.conf

[global]

index-url = http://mirrors.aliyun.com/pypi/simple/

trusted-host=mirrors.aliyun.com ## add this line fix https warning


[install]

trusted-host=mirrors.aliyun.com


1
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:195640次
    • 积分:2620
    • 等级:
    • 排名:第13991名
    • 原创:88篇
    • 转载:8篇
    • 译文:0篇
    • 评论:15条
    最新评论