HDU 1062 Text Reverse

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output

hello world!
I’m from hdu.
I like acm.

题目大意:

先输入一个n,表示有n组测试数据。输入为一个字符串,但是这个字符串是逆向的,你需要将更改好的字符串输出。

c++

#include <iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
    int a,b,c,d,e;
    char m[1000];
    cin>>a;
    getchar();
    while(a--)
    {
        gets(m);      //gets可以读入空格
        b=strlen(m);
        e=0;        //e用来存放开始与空格后一位
        while(1)
        {
            for(c=e;c<b;c++)
            {
                if(m[c]==' ')
                    break;
            }
            for(d=c-1;d>=e;d--)  //将其倒着输出
            {
                cout<<m[d];
            }
            if(c>=b)
                break;
            e=c+1;
            cout<<" ";
        }
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值