hdu5641King's Phone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)


Problem Description
In a military parade, the King sees lots of new things, including an Andriod Phone. He becomes interested in the pattern lock screen.

The pattern interface is a  3×3  square lattice, the three points in the first line are labeled as  1,2,3 , the three points in the second line are labeled as  4,5,6 , and the three points in the last line are labeled as  7,8,9 。The password itself is a sequence, representing the points in chronological sequence, but you should follow the following rules:

- The password contains at least four points.


- Once a point has been passed through. It can't be passed through again.

- The middle point on the path can't be skipped, unless it has been passed through( 3427  is valid, but  3724  is invalid).

His password has a length for a positive integer  k(1k9) , the password sequence is  s1,s2...sk(0si<INT_MAX)  , he wants to know whether the password is valid. Then the King throws the problem to you.
 

Input
The first line contains a number&nbsp; T(0<T100000) , the number of the testcases.

For each test case, there are only one line. the first first number&nbsp; k ,represent the length of the password, then  k  numbers, separated by a space, representing the password sequence  s1,s2...sk .
 

Output
Output exactly  T  lines. For each test case, print `valid` if the password is valid, otherwise print `invalid`
 

Sample Input
  
  
3 4 1 3 6 2 4 6 2 1 3 4 8 1 6 7
 

Sample Output
  
  
invalid valid valid hint: For test case #1:The path $1\rightarrow 3$ skipped the middle point $2$, so it's invalid. For test case #2:The path $1\rightarrow 3$ doesn't skipped the middle point $2$, because the point 2 has been through, so it's valid. For test case #2:The path $8\rightarrow 1 \rightarrow 6 \rightarrow 7$ doesn't have any the middle point $2$, so it's valid.
 

Source



+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++




#include <string.h>
#include <stdio.h>
#include <iostream>
using namespace std;
int main()
{
   // freopen("in.txt", "r", stdin);
   // freopen("outt.txt", "w", stdout);
    int n,m,k;
    int a[12];
    int b[102];
    scanf("%d",&k);
    while(k--)
    {


        scanf("%d",&n);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);


        if(n<4)
        {
            printf("invalid\n");
            continue;
        }
        int f=1;
        for(int i=0; i<n-1; i++)
        {
            if(a[i]>9||a[i]<1)//一开始想到了,但是看成K,wa好几次
                {
                f=0;
                break;
            }
            if(b[a[i]]==1)
            {
                f=0;
                break;
            }
            b[a[i]]=1;
            if(a[i]==1)
            {
                if((a[i+1]==3&&b[2]==0)||(a[i+1]==7&&b[4]==0)||(a[i+1]==9&&b[5]==0))
                    f=0;
            }
            if(a[i]==2)
            {
                if(a[i+1]==8&&b[5]==0)
                    f=0;
            }
            if(a[i]==3)
            {
                if((a[i+1]==1&&b[2]==0)||(a[i+1]==7&&b[5]==0)||(a[i+1]==9&&b[6]==0))
                    f=0;
            }
            if(a[i]==4)
            {
                if(a[i+1]==6&&b[5]==0)
                    f=0;
            }
            if(a[i]==6)
            {
                if(a[i+1]==4&&b[5]==0)
                    f=0;
            }
            if(a[i]==7)
            {
                if((a[i+1]==1&&b[4]==0)||(a[i+1]==3&&b[5]==0)||(a[i+1]==9&&b[8]==0))
                    f=0;
            }
            if(a[i]==8)
            {
                if(a[i+1]==2&&b[5]==0)
                    f=0;
            }
            if(a[i]==9)
            {
                if((a[i+1]==1&&b[5]==0)||(a[i+1]==3&&b[6]==0)||(a[i+1]==7&&b[8]==0))
                    f=0;
            }
             // cout<<a[i]<<" "<<b[i]<<endl;
        }
        if(b[a[n-1]]==1||a[n-1]>9||a[n-1]<1)
            f=0;
        if(f==0)
          printf("invalid\n");
        else
            printf("valid\n");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值