20110727 个人赛C题~

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5Ab3bd

Sample Output

2

这是一道挺有趣的题~大意是给出一个字符串~求要添加几个字符才能是该字符串成为回文~

乍看之下~有些没思路~难道要一每个字符为对称轴去试~
其实将字符串反序~计算出两字符串最大公共序列的长度~
则所求即为字符串长度-最大公共序列长度
原因是字符串与反序字符串的公共序列即为对称之处~
那剩下的为不对称之处~只需要依次添加使之对称就行啦~
#include"cstdio"
#include"cstring"
char s1[5000],s2[5000];
int i,j;
int a[2][5001];
int n;
int s;

int main()
{
//	freopen("01in.txt","r",stdin);
	while(scanf("%d\n%s",&n,s1)!=EOF)
	{
	for(i=0;i<n;i++)
		s2[i]=s1[n-1-i];
	memset(a,0,sizeof(a));
	for(i=1;i<=n;i++)//动态规划 求最大公共序列
	{
		s=i%2;
		for(j=1;j<=n;j++)
		{
			if(s1[i-1]==s2[j-1])
				a[s][j]=a[(s+1)%2][j-1]+1;
			else
				a[s][j]=(a[(s+1)%2][j]>a[s][j-1]?a[(s+1)%2][j]:a[s][j-1]);
		}
	}
	printf("%d\n",n-((a[0][n]>a[1][n])?a[0][n]:a[1][n]));
	}
}  


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值