PAT A1016. Phone Bills (25)

13 篇文章 0 订阅

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#define Max 1001
using namespace std;
int Cost[24];
struct person{
	char Name[21];
	int Imm,Id,Ih,Im;
	int cost[13];
	int mi[13];
	int gr;
	int vi;
}S[Max];
bool cmp(person a,person b)
{
	if(strcmp(a.Name,b.Name)!=0) return strcmp(a.Name,b.Name)<0; 
	else if(a.Imm!=b.Imm) return a.Imm<b.Imm;
	else if(a.Id!=b.Id) return a.Id<b.Id;
	else if(a.Ih!=b.Ih) return a.Ih<b.Ih;
	else if(a.Im!=b.Im) return a.Im<b.Im;
}
int getm(person a,person b)
{
	int cm,ch=0;
	for(int i=0;i<24;i++)
		ch+=60*Cost[i];
	cm=b.Im*Cost[b.Ih]+(60-a.Im)*Cost[a.Ih];//将零头分钟计算出来
	a.Ih++;
	if(a.Ih>=24)
	{
		a.Ih-=24;
		a.Id--;
	}
	if(a.Ih>b.Ih)
	{
		a.Id++;
		for(int i=a.Ih;i<24;i++)
			cm+=60*Cost[i];
		for(int i=0;i<b.Ih;i++)
			cm+=60*Cost[i];
	}
	cm+=(b.Id-a.Id)*ch;

	return cm;
}
int getf(person a,person b)
{
	int cm,ch=0;
	for(int i=0;i<24;i++)
		ch+=60;
	cm=b.Im+(60-a.Im);//将零头分钟计算出来
	a.Ih++;
	if(a.Ih>=24)
	{
		a.Ih-=24;
		a.Id--;
	}
	if(a.Ih>b.Ih)
	{
		a.Id++;
		for(int i=a.Ih;i<24;i++)
			cm+=60;
		for(int i=0;i<b.Ih;i++)
			cm+=60;
	}
	cm+=(b.Id-a.Id)*ch;

	return cm;
}
int main()
{
	for(int i=0;i<24;i++)
	{
		scanf("%d",&Cost[i]);
	}
	int n,fn=0,fo=0;
	int moncost=0;
	char act[10];
	scanf("%d",&n);
	getchar();
	for(int i=0;i<n;i++)
	{
		scanf("%s %d:%d:%d:%d %s",S[i].Name,&S[i].Imm,&S[i].Id,&S[i].Ih,&S[i].Im,act);
		if(act[1]=='n') S[i].gr=1;
		else if(act[1]=='f') S[i].gr=2;
		S[i].vi=0;
		
	}
	sort(S,S+n,cmp);
	for(int i=0;i<n;i++)
	{
		if(i!=0&&moncost!=0){
		if(strcmp(S[i].Name,S[i-1].Name)!=0)
									{
						                   printf("Total amount:$.2f\n",(double)(moncost/100.0));
										   fo=fn=0;
										   moncost=0;
									}
		else if(S[i+1].Imm!=S[i-1].Imm)
									{
						                   printf("Total amount:$.2f\n",(double)(moncost/100.0));
										   fo=fn=0;
										   moncost=0;
		}}
		if(fo==1||S[i].gr==2) continue;
		else {
			fo==1;
	    	for(int j=i+1;j<n;j++)
			{
				
				if(strcmp(S[i].Name,S[j].Name)!=0) break;
				else {
					if(S[j].gr!=2) break;
					else {
						if(S[j].Imm!=S[i].Imm) break;
						else {
							   
							   fo=0;
							   if(fn==0){
								   printf("%s %02d\n",S[i].Name,S[i].Imm);
								   fn=1;
							   }
					              printf("%d:%d:%d %d:%d:%d %d $%.2f\n",S[i].Id,S[i].Ih,S[i].Im,S[j].Id,S[j].Ih,S[j].Im,getf(S[i],S[j]),(double)(getm(S[i],S[j])/100.0));
					                moncost+=getm(S[i],S[j]);
									
									
									break;
				              
							   
						        }
				          }
				}
			}
		}
		
									if(i>=n-1)
									{
										   printf("Total amount: $.2f\n",(double)(moncost/100.0));
										   fo=fn=0;
									}
	}
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值