HDU 1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 189909    Accepted Submission(s): 36279


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1004  1003  1008  1005  1089 
 

Statistic |  Submit |  Discuss |  Note

/*
	Name: HDU 1002	
	Copyright: Analyst 
	Author: Analyst 
	Date: 04/03/14 11:34
	Description: dev-cpp 5.5.3
*/
#include <iostream>
#include <string>
using namespace std;

int main()
{
	int time, i, j, len1, len2,len;
	string str[21][2];
	int arr[1001];
	
	while (scanf("%d", &time) != EOF)
	{
		for (i = 0; i < time; ++i)
		{
			cin >> str[i][0] >> str[i][1];
		}
		for (i = 0; i < time; ++i)
		{
			len1 = str[i][0].size();
			len2 = str[i][1].size();
			len = len1 > len2 ? len1 : len2;   //得到最长的串长度 
			
			memset(arr,0,sizeof(arr));         //将arr[],全部初始化为0 

			for (j = len; j > 0; --j)          //按位相加 
			{
				if (len1 > 0 && len2 > 0)
					arr[j] += (str[i][0][--len1]-'0' + str[i][1][--len2]-'0');
				else if (len1)
					arr[j] += str[i][0][--len1]-'0';
				else
					arr[j] += str[i][1][--len2]-'0';
					
				if (arr[j] >= 10)              //进位 
				{
					++arr[j-1];
					arr[j] -= 10;
				}
			}
			printf("Case %d:\n",i+1);
			cout << str[i][0] <<" + "<<str[i][1] <<" = ";
			for (int k = arr[0] == 0?1:0 ; k <= len; ++k) 
				printf("%d",arr[k]);
			printf("\n");
			if (i != time-1)                   //注意最后一行不要打印 换行 
				printf("\n");
		}
	}
	return 0;
}

102152362014-03-04 16:41:42Accepted10020MS328K1121 BC++Analyst


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值