PAT (Advanced Level) Practise 1077 Kuchiguse (20)

1077. Kuchiguse (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

    Sample Input 1:
    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    
    Sample Output 1:
    nyan~
    
    Sample Input 2:
    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    
    Sample Output 2:

    nai

    找一下最长公共后缀,直接暴力判断就好了。

    #include<cstdio>
    #include<stack>
    #include<cstring>
    #include<string>
    #include<vector>
    #include<queue>
    #include<iostream>
    #include<algorithm>
    #include<functional>
    using namespace std;
    const int INF = 0x7FFFFFFF;
    const int maxn = 1e3 + 15;
    int n, len[maxn];
    char s[maxn][maxn];
    string ans;
    
    int main()
    {
    	scanf("%d", &n);	getchar();
    	for (int i = 0; i < n; i++) gets(s[i]), len[i] = strlen(s[i]);
    	for (int i = 1; i; i++)
    	{
    		int flag = 1;
    		for (int j = 1; j < n; j++)
    		{
    			if (len[j] < i) { flag = 0; break; }
    			if (s[j][len[j] - i] != s[j - 1][len[j - 1] - i])
    			{
    				flag = 0;	break;
    			}
    		}
    		if (flag) ans = s[0][len[0] - i] + ans; else break;
    	}
    	if (ans == "") ans = "nai";
    	cout << ans << endl;
    	return 0;
    }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值