HDU4405:Aeroplane chess(概率dp & 期望)



Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4200    Accepted Submission(s): 2659


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
      
      
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
      
      
1.1667 2.3441
 

Source
题意:X轴上玩家在1点,每次抛色子向前走,或者有些点相连的要直接飞过去,问到N点抛色子的期望数。

思路:求期望,dp[i]表示在i点到N点的期望值,显然dp[N]=0,需要求dp[0],无直飞路线下dp[i]=dp[i+1]/6+dp[i+2]/6+...+dp[i+6]/6+1,倒推求解即可。

# include <iostream>
# include <cstdio>
# include <vector>
# include <cstring>
using namespace std;
int son[100010];
double dp[100010];
int main()
{
    int n, m, a, b;
    while(~scanf("%d%d",&n,&m),n+m)
    {
        memset(son, 0, sizeof(son));
        memset(dp, 0, sizeof(dp));
        while(m--)
        {
            scanf("%d%d",&a,&b);
            son[a] = b;
        }
        dp[n] = 0;
        for(int i=n-1; i>=0; --i)
        {
            if(!son[i])
            {
                dp[i] = 1;
                for(int j=1; j<=6; ++j)
                    dp[i] += dp[i+j]/6;
            }
            else
                dp[i] = dp[son[i]];
        }
        printf("%.4f\n",dp[0]);
    }
    return 0;
}



Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4200    Accepted Submission(s): 2659


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
       
       
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
       
       
1.1667 2.3441
 

Source
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值