hdu 1242 Rescue

Rescue

http://acm.hdu.edu.cn/showproblem.php?pid=1242

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4611    Accepted Submission(s): 1708

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

 

Sample Output
  
  
13
 晕,被水题给水了
代码:
//hdu 1242 Rescue 记住先判断在往各个方向扫描!!!
//还有memset(mark,0,sizeof(mark));
//不要写成memset(mark,0,sizeof(mark[0][0]));!!!!×××

#include<iostream>
#include<queue>
using namespace std;
int n,m;
int i,j;
char map[210][210];
int mark[210][210];
int dir[][2]={0,1,1,0,0,-1,-1,0};
struct node
{
 int x;
 int y;
 int step;
}begin;
void dfs()
{
    int i;
    node p,temp;
    queue<node> q;
    q.push(begin);
    while(q.size())
    {
        p=q.front();
        q.pop();
        if('r'==map[p.x][p.y])
  {
   printf("%d/n",p.step);
   return ;  //退出函数
  }
  
  if('x'==map[p.x][p.y])  //留空退步
  {
   map[p.x][p.y]='.';
   p.step++;
   q.push(p);
  }
  else
   for(i=0;i<4;i++)
   {
    temp.x=p.x+dir[i][0];
    temp.y=p.y+dir[i][1];
    if(temp.x>n||temp.x<0||temp.y>m||temp.y<0||map[temp.x][temp.y]=='#'||mark[temp.x][temp.y]!=0)   //边界判断
     continue;
                temp.step=p.step+1;
                mark[temp.x][temp.y]=1;
                q.push(temp);
            }
 }
 
 printf("Poor ANGEL has to stay in the prison all his life./n");
}
int main()
{
 while(scanf("%d%d",&n,&m)!=EOF)
 {
  memset(mark,0,sizeof(mark));
  
  
  for(i=0;i<n;i++)
  {
   getchar();
   for(j=0;j<m;j++)
   {  
    scanf("%c",&map[i][j]);
    if(map[i][j]=='a') //找出起点
    {
     begin.x=i;
     begin.y=j;
     begin.step=0;
    }
   }
  }
  //  for(i=0;i<n;i++)
  //  {
  //   cout<<map[i]<<endl;
  //  }
  
  dfs(); //dfs
  
  
 }
 return 0;
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值