1010. Radix (25)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible


这道题是给出两个数,还有给出其中一个数的基数,求出另一个数的基数使得它们相等,如果没有这样的基数则输出Impossible。这个题一看觉得很简单,以为直接算出第一个数,以及尝试以2到36为基数算出第二个数看是否等于第一个数,就能得到结果,但这样做只能得18分,试了很久都没右发现哪里错。然后上网看看别人做的,原来第二个数的基数不一定是小于36...这样可能的答案范围就更广了,所以要用二分搜索(这里要注意下限和上限,下限要大于第二个数的每一位数,上限要小于第一个数)。然后又上交了一次,只有24分,错了一个。再检查一下想到了基数大的时候有可能超出了正整数的范围,变成小于0,所以还要注意这种情况。


代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include<cctype>
using namespace std;

long long get_num(char c)
{
	if(isdigit(c)) return c-'0';
	else return c-'a'+10;
}

int main()
{
	string n1,n2;
	long long tag,radix;
	cin>>n1>>n2>>tag>>radix;
	
	if(radix<2) cout<<"Impossible";
	
	if(tag==2) swap(n1,n2);
	long long num1=0,num2=0;
	for(int i=0;i<n1.size();i++)
	{
		num1=num1*radix+get_num(n1[i]);
	}
	long long left=2;
	for(int i=0;i<n2.size();i++)
	{
		left=max(left,get_num(n2[i])+1);
	}
	
	long long right=num1+1;
	while(left<=right)
	{
		long long mid=(left+right)/2;
		num2=0;
		for(int i=0;i<n2.size();i++)
		{
			num2=num2*mid+get_num(n2[i]);
		}
		if(num2==num1) 
		{
			cout<<mid;
			return 0;
		}
		else if(num2>num1||num2<0)
		{
			right=mid-1;
		}
		else
		{
			left=mid+1;
		}
	}
	
	cout<<"Impossible";
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值