1089. Insert or Merge (25)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:
10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
Sample Output 1:
Insertion Sort
1 2 3 5 7 8 9 4 6 0
Sample Input 2:
10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
Sample Output 2:
Merge Sort
1 2 3 8 4 5 7 9 0 6

判断给出的第二个序列(还没完全排序)用的是插入排序还是合并排序,且求出下一步排序得到的结果。插入排序的特点是序列的前面部分是已经排好序的,还没排序的部分和原序列的那部分是一样的,然后不符合这个特点的就是合并排序,因为题目只有这两种排序。插入排序的下一步就是将还没排序部分的第一个点插入到前面的序列的合适的位置。合并排序的下一步是先算出当前排序的程度m(序列每2,4,8...m个数一组都已经排序好),然后下一步就是每m*2一组进行排序。


代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

void print(vector<int>a)
{
	printf("%d",a[0]);
	for(int i=1;i<a.size();i++)
	{
		printf(" %d",a[i]);
	}
}

bool issorted(vector<int>a,int l,int r)
{
	int n=a.size();
	for(int i=l+1;i<r&&i<n;i++)
	{
		if(a[i]<a[i-1]) return false;
	}
	return true;
}

int main()
{
	int n,i,index;
	cin>>n;
	vector<int>a(n),b(n);
	for(i=0;i<n;i++)
	{
		cin>>a[i];
	}
	for(i=0;i<n;i++)
	{
		cin>>b[i];
	}
	for(i=1;i<n;i++)
	{
		if(b[i]<b[i-1]) break;
	}
	index=i;
	for(i;i<n;i++)
	{
		if(b[i]!=a[i]) break;
	}
	if(i==n)
	{
		printf("Insertion Sort\n");
		int tmp=b[index],j;
		for(j=index-1;j>=0;j--)
		{
			if(tmp<b[j])
			{
				b[j+1]=b[j];
			}
			else
			{
				break;
			}
		}
		b[j+1]=tmp;
		print(b);
	}
	else
	{
		printf("Merge Sort\n");
		int m=2,flg=0;
		while(true)
		{
			for(int j=0;j<n;j+=m)
			{
				if(!issorted(b,j,j+m))
				{
					flg=1;
					break;
				}
			}
			if(flg==1) break;
			m*=2;
		}
		for(int j=0;j<n;j+=m)
		{
			if(j+m>=n)
			{
				sort(b.begin()+j,b.end());
			}
			else
			{
				sort(b.begin()+j,b.begin()+j+m);
			}
		}
		print(b);
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值