1115. Counting Nodes in a BST (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6

计算一颗二叉搜索树最底两层的节点数,并且求和。首先根据输入的数值建立二叉搜索树,这里用的是递归的方法。然后用bfs的方法计算最后最底两层的节点数,最后按照题目要求输出答案。


代码:

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <queue>
using namespace std;

struct node
{
	int val;
	node *left,*right;
	node(int v):val(v),left(NULL),right(NULL){}
};

void build(node *&root,int val)
{
	if(root==NULL)
	{
		root=new node(val);
		return;
	}
	if(val<=root->val) build(root->left,val);
	else build(root->right,val);
}

int main()
{
	int n;
	cin>>n;
	node *root=NULL;
	for(int i=0;i<n;i++)
	{
		int v;
		cin>>v;
		build(root,v);
	}
	
	queue<node*>que;
	que.push(root);
	int n1=0,n2=0;
	while(!que.empty())
	{
		n2=n1;
		n1=que.size();
		for(int i=0;i<n1;i++)
		{
			node *tmp=que.front();
			que.pop();
			if(tmp->left) que.push(tmp->left);
			if(tmp->right) que.push(tmp->right);
		}
	}
	printf("%d + %d = %d\n",n1,n2,n1+n2);
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值