HDOJ 1018 Big Number


Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18071    Accepted Submission(s): 8115


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

Source
 

Recommend
JGShining
 


裸算必然TLE。。。我无耻的翻解题报告了。 数学题


算法一:利用公式 log10(n!)=log10(1*2*3…*n)=log10(1)+log10(2)+…+log10(n)

#include <iostream>
#include <cmath> 
using namespace std;
int main(int argc, char *argv[])
{
	int t,i,j,n; double sum;
	cin>>t;
	for (i=0;i<t;++i){
		cin>>n; sum=0.0;
		for(j=1;j<=n;++j)
			sum+=log10(j);
		n=round(sum+0.5);
		cout<<n<<endl;
	}
	return 0;
}


差点TLE。


算法二:

《计算机程序设计艺术》中给出了另一个公式
   n! = sqrt(2*π*n) * ((n/e)^n) * (1 + 1/(12*n) + 1/(288*n*n) + O(1/n^3))
   其中 π = acos(-1)    e = exp(1)

有了这个公式就好好办了,两边对10取对数:
忽略log10(1 + 1/(12*n) + 1/(288*n*n) + O(1/n^3)) ≈ log10(1) = 0
得到公式  log10(n!) = log10(sqrt(2 * pi * n)) + n * log10(n / e)
用C++写时round(n+0.5)会出错,要用(int)n+1。。。。。C的取整函数真纠结啊,怀念Pascal中


果断 0MS AC

#include <iostream>
#include <cmath> 
using namespace std;
int main(int argc, char *argv[])
{
	int t,n;
 	double PI = acos(-1.0),e = exp(1.0);
 	cin>>t;
 	for (int i=0;i<t;++i) {
		cin>>n;
 		n=log10(sqrt(2*PI*n))+(n*log10(n/e))+1;
 		cout<<int(n)<<endl;
  }
	return 0;
}

kdwycz的网站:  http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值