POJ 3984 迷宫问题 广搜迷宫解法

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

本题是经典的迷宫搜索问题了,使用广搜比使用深搜效率要高。

思路关键点:

1 从终点出发查找起点,这样方便记录路径

2 每次查找到下一个空格,可走方格之后,可以马上标识该格为不可走了

3 找到起点之后,马上可以返回

关键是第二点为什么会成立?

因为我们需要找最短路径,只要最先可以达到,那么就肯定是最短路径,不需要从其他方向进入了。

#include <stdio.h>
#include <string.h>
#include <limits.h>
#include <queue>
#include <algorithm>
#include <xutility>
using namespace std;

const int N = 5;
int Maze[N][N];
pair<int, int> path[N][N];
const int BLOCK = 1;
int dx[] = {1, -1, 0, 0};
int dy[] = {0, 0, 1, -1};

inline bool isLegal(int x, int y)
{
	return x>=0 && y>=0 && x<N && y<N && !Maze[x][y];
}

template<typename T>
inline bool equ(T t1, T t2) { return t1 == t2; }

void bfsGetPath(int sx = 0, int sy = 0, int ex = 4, int ey = 4)
{
	queue<pair<int, int> > qu;
	qu.push(make_pair(ex, ey));//初始条件,从终点开始搜索到起点,方便记录路径
	path[ex][ey] = make_pair(-1, -1);//记录终点结束条件值
	Maze[ex][ey] = BLOCK;//标志为不可走

	while (!qu.empty())
	{
		pair<int, int> fa = qu.front();	qu.pop();
		for (int i = 0; i < 4; i++)
		{
			int nx = dx[i] + fa.first, ny = dy[i] + fa.second;
			if (!isLegal(nx, ny)) continue;//跳过不可走的方格

			path[nx][ny] = fa;//记录路径
			if (equ(nx, sx) && equ(ny, sy)) return;//找到起点可以返回

			qu.push(make_pair(nx, ny));//入队列
			Maze[nx][ny] = BLOCK;//入队列的方格,可以马上置为不可走状态
		}
	}
}

int main()
{
	for (int i = 0; i < N; i++)
	{
		for (int j = 0; j < N; j++)
		{
			scanf("%d", Maze[i]+j);
		}
	}

	bfsGetPath();

	int x = 0, y = 0;//起点开始输出路径点
	while (x != -1)
	{
		printf("(%d, %d)\n", x, y);
		int nx = path[x][y].first;
		int ny = path[x][y].second;
		x = nx, y = ny;//注意需要使用中间变量nx, ny
	}
	return 0;
}



  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫索算法,找到从起点到终点的最短路径。可以使用广度优先索或者深度优先索算法来解决这个问题。 下面是一个使用广度优先索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先索算法,首先读入迷宫地图,然后从起点开始进行索,直到找到终点为止。在索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值