POJ 3181 Dollar Dayz 动态规划法题解

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

Source


本题也是一种背包问题,就是需要求出有多少种组合。

本题的新意就是:

1 利用两个long long数表示大数的高位和低位就能满足不溢出了

2 高位和低位需要仔细计算好


建模:

dp[i][j]:表示计算当前i物品的时候有j钱币的时候有多少种组合。

那么状态转换:dp[i][j] = dp[i-1][j] + dp[i][j-i]//dp[i-1][j]表示前一种物品计算出的组合数,也就是不买i物品的组合数, dp[i][j-i]表示空出i钱币购买i物品的组合数

难点:

仔细观察,会发现其实不单止不用二维数组,就连滚动数组都不需要使用。

如下面程序,直接使用一维数组就能得到答案了。

#include <stdio.h>
#include <vector>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <string>
#include <limits.h>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;

const int MAX_N = 1001;
long long hiBit[MAX_N], lowBit[MAX_N];
const long long MOD = (long long) 1E18;//lowBit保存18个0,为了输出格式一致,之后就要进位了,其中long long可以保存19位数

void getCombinations(int N, int K)
{
	memset(hiBit, 0, sizeof(long long) * (N+1));
	memset(lowBit, 0, sizeof(long long) * (N+1));
	lowBit[0] = 1LL;
	for (int i = 1; i <= K; i++)
	{
		for (int j = i; j <= N; j++)
		{
			lowBit[j] += lowBit[j-i];//买和不买i物品的和,就是当前组合和了
			hiBit[j] += lowBit[j] / MOD + hiBit[j-i];//错误:忘记hiBit[j-i]
			lowBit[j] %= MOD;//保存低位
		}
	}
}

int main()
{
	int N, K;
	while (~scanf("%d %d", &N, &K))
	{
		getCombinations(N, K);
		if (hiBit[N] > 0LL) printf("%lld", hiBit[N]);
		printf("%lld\n", lowBit[N]);
	}
	return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值