解决OS X 10.11 升级 cocoapods带来的问题

转载 2015年11月17日 17:48:07

尴尬今天手贱升级了OS X 10.11,cocoaPods失效!惊恐惊恐惊恐

Im assuming you're running OS X 10.11.

This is happening because Apple has enabled rootless on the new install.

If you type sudo nvram boot-args="rootless=0"; sudo reboot in terminal.app Your computer will reboot with it disabled.

Once that is done, type

sudo gem install cocoapods -V

the -V is for verbose and will spit out any errors if they happen.

This also works.

sudo gem install -n /usr/local/bin cocoapods  

  • pod install一下后,提示:

AdeMacBook-Pro:cbt-ios-app A$ pod install  
Updating local specs repositories  
xcrun: error: active developer path ("/Applications/Xcode6.app/Contents/Developer") does not exist, use `xcode-select --switch path/to/Xcode.app` to specify the Xcode that you wish to use for command line developer tools (or see `man xcode-select`)  
xcrun: error: active developer path ("/Applications/Xcode6.app/Contents/Developer") does not exist, use `xcode-select --switch path/to/Xcode.app` to specify the Xcode that you wish to use for command line developer tools (or see `man xcode-select`)  
Creating shallow clone of spec repo `master-1` from `https://github.com/CocoaPods/Specs.git`  
[!] Unable to add a source with url `https://github.com/CocoaPods/Specs.git` named `master-1`.
You can try adding it manually in `~/.cocoapods/repos` or via `pod repo add`.  

再加一句,完美解决得意

相关文章推荐

升级OS X 10.11后CocoaPods的安装(问题与解决方法)

OS X更新到10.11后,CocoaPods的安装和以前有了点不同。 以前安装cocoapods的时候用的是这句: $ sudo gem install cocoapods 现在要改成这句:...

Mac OS X 10.11升级带来的 cocoapods问题

欢迎加QQ群讨论:157672725昨天升级完Mac OS X 10.11,发现cocoapods不能用了。 后面用以下命令解决了,在此记录希望能帮到需要的朋友。 如在执行以下命令时出现问题,请看...
  • catch01
  • catch01
  • 2015年10月15日 16:10
  • 343

升级 OS X 10.11 cocoapods 使用不正常的问题

升级 OS X 10.11 cocoapods 使用不正常的问题  字数1292 阅读1077 评论0 喜欢6 Rootless 的说明 在OS X 10.11中苹果引入的Roo...

升级Mac os x 10.10+xcode6.1之后,Cocoapods出现问题的解决方案

在升级Mac OS X 10.10+Xcode 6.1之后,Cocoapods的依赖库管理也相应的进行了升级。目前最新的Release版本是 0.34。在之前的版本中,进行库更新和管理时,会遇到如下错...

解决 Mac OS X 10.11 安装 sip 没有权限的问题

在搭建 PYQT 的过程中我遇上了一个非常恶心的问题,在安装 sip 的时候编译源码之后的安装过程中一直提示我:Operation not permitted ,我甚至重装了系统也无济于事,最终通过查...

Cocoapods安装步骤(OS X 10.11环境)

1.升级Ruby环境sudo gem update --system如果Ruby没有安装,请参考 如何在Mac OS X上安装 Ruby运行环境2.安装CocoaPods时我们要访问cocoapods...

cocoapods 环境配置及使用 (MAC OS X 10.11 更新后的新的安装方式)

一、 创建使用环境      1、 安装ruby 环境           (1)安装 RVM                   a.  $ curl -L https://get.rvm.io ...

iOS 第三方框架管理cocoapods 关于Mac 10.11 系统升级无法使用的问题

一、什么是CocoaPods? 前言: 思考如何引入一个第三方框架。 例如: 百度地图SDK、友盟、ShareSDK、 信鸽推送等。 从github或某处下载第三方SDK工程中导入所需要的SDK的...

Mac OS X 10.11.x 安装 Cocoapods 心路历程

我用的是最新版的 Mac OS X 10.11.6 系统,在安装 Cocoapods 的过程中也是遇到了一些问题,下面就整个安装过程以及过程中出现的问题和解决方案作一下总结。 Cocoapods 是什...

OSX: 尝试禁止Bonjour广播带来的问题解决(10.11.x或更新)

前些日子,希望尝试禁止Bonjour广播来减少其在局域网内的影响,于是找了一些方案: 1. 最老的的方案,适合于10.9的是: launchctl unload -w /System/Librar...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:解决OS X 10.11 升级 cocoapods带来的问题
举报原因:
原因补充:

(最多只允许输入30个字)