uva 1339 Ancient Cipher(字符串处理)

942 篇文章 2 订阅
232 篇文章 0 订阅
本文介绍了古罗马时期的一种加密技术,结合了替换密码和置换密码。加密过程首先使用替换密码,然后应用置换密码。解题思路是通过统计字符频率并排序来验证猜测的原文是否正确。
摘要由CSDN通过智能技术生成

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher. Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from `A' to `Y' to the next ones in the alphabet, and changes `Z' to `A', to the message ``VICTORIOUS'' one gets the message ``WJDUPSJPVT''. Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation $ \langle$2, 1, 5, 4, 3, 7, 6, 10, 9, 8$ \rangle$ to the message ``VICTORIOUS'' one gets the message ``IVOTCIRSUO''. It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message ``VICTORIOUS'' with the combination of the ciphers described above one gets the message ``JWPUDJSTVP''. Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

Input 

Input file contains several test cases. Each of them consists of two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet. The lengths of both lines of the input file are equal and do not exceed 100.

Output 

For each test case, print one output line. Output ` YES ' if the message on the first line of the input file could be the result of encrypting the message on the second line, or ` NO ' in the other case.

Sample Input 

JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES

Sample Output 

YES
NO
YES
YES
NO
题目大意:给出两个字符串,判断两个字符串中的字符是否一一对应,一一对应指的是字符串中某个字符的个数与另一个字符串中某一个字符的个数相同(字符不可以重复考虑)

解题思路:开个数组统计字符的个数,用sort函数排序后比较。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int N = 105;
const int M = 26;

bool judge (char a[], char b[]) {
    int n[M], m[M];
    memset(n, 0, sizeof(n));
    memset(m, 0, sizeof(m));
    int len = strlen(a);
    for (int i = 0; i < len; i++) {
	n[a[i] - 'A']++;
	m[b[i] - 'A']++;
    }
    sort(n, n + M);
    sort(m, m + M);
    return memcmp(n, m, sizeof(n)) == 0;
}

int main() {
    char str[2][N];
    while (gets(str[0])) {
	gets(str[1]);
	printf("%s\n", judge(str[0], str[1]) ? "YES" : "NO");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值