网络流24题1.飞行员配对方案问题

飞行员配对方案问题

Description

第二次世界大战时期,英国皇家空军从沦陷国征募了大量外籍飞行员。由皇家空军派出的每一架飞机都需要配备在航行技能和语言上能互相配合的 2 名飞行员,其中 1 名是英国飞行员,另 1 名是外籍飞行员。在众多的飞行员中,每一名外籍飞行员都可以与其他若干名英国飞行员很好地配合。如何选择配对飞行的飞行员才能使一次派出最多的飞机。对于给定的外籍飞行员与英国飞行员的配合情况,试设计一个算法找出最佳飞行员配对方案,使皇家空军一次能派出最多的飞机。
对于给定的外籍飞行员与英国飞行员的配合情况,编程找出一个最佳飞行员配对方案,使皇家空军一次能派出最多的飞机。

Input

文件第 1 行有 2 个正整数 m 和 n。n 是皇家空军的飞行员总数(n<100);m 是外籍飞行员数。外籍飞行员编号为1~m;英国飞行员编号为 m+1~n。接下来每行有 2 个正整数 i 和 j,表示外籍飞行员 i 可以和英国飞行员 j 配合。文件最后以2个-1结束。

Output

程序运行结束时,将最佳飞行员配对方案输出到文件 output.txt 中。第 1 行是最佳飞行员配对方案一次能派出的最多的飞机数 M。接下来 M 行是最佳飞行员配对方案。每行有 2个正整数 i 和 j,表示在最佳飞行员配对方案中,飞行员 i 和飞行员 j 配对。如果所求的最佳飞行员配对方案不存在,则输出‘No Solution!’。

Sample Input

5 10
1 7
1 8
2 6
2 9
2 10
3 7
3 8
4 7
4 8
5 10
-1 -1

Sample Output

4
1 7
2 9
3 8
5 10

题目大意

求二分图最大匹配。

题解

建立一个超级源一个超级汇,源向每个外籍飞行员连一条容量为1的边,每个英国飞行员向汇连一条容量为1的边,每个可以组队的外籍飞行员和英国飞行员间连一条容量为1的边。然后跑最大流,满流边就是一种匹配。
但是由于不会写spj,只能用手上的数据删去输出方案测试通过。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int N = 200 + 10, inf = 0x3f3f3f3f;

int n, m, tot, ans;
struct Edge{
    int fr, to, cap, flow;
}edg[N*N];
int hd[N], nxt[N*N];
int s, t;
int d[N], q[N], vis[N], dfn, cur[N];

void insert(int u, int v, int w){
    edg[tot].fr = u, edg[tot].to = v, edg[tot].cap = w;
    nxt[tot] = hd[u]; hd[u] = tot;
    tot++;
    edg[tot].fr = v, edg[tot].to = u;
    nxt[tot] = hd[v]; hd[v] = tot;
    tot++;
}
void init(){
    memset(hd, -1, sizeof(hd));
    scanf("%d%d", &m, &n);
    s = 0, t = n + 1;
    int x, y;
    while(scanf("%d%d", &x, &y) && x != -1) insert(x, y, 1);
    for(int i = 1; i <= m; i++) insert(0, i, 1);
    for(int i = m + 1; i <= n; i++) insert(i, n+1, 1);
}


bool bfs(){
    int head = 1, tail = 1;
    d[s] = 0; q[1] = s; vis[s] = ++dfn;
    while(head <= tail){
        int u = q[head++];
        for(int i = hd[u]; i >= 0; i = nxt[i]){
            Edge &e = edg[i];
            if(vis[e.to] == dfn || e.cap <= e.flow) continue;
            vis[e.to] = dfn;
            d[e.to] = d[u] + 1;
            q[++tail] = e.to;
        }
    }
    return vis[t] == dfn;
}
int dfs(int x, int a){
    if(x == t || a == 0) return a;
    int flow = 0, f;
    for(int &i = cur[x]; i >= 0; i = nxt[i]){
        Edge &e = edg[i];
        if(d[e.to] == d[x] + 1 && (f = dfs(e.to, min(a, e.cap-e.flow))) > 0){
            e.flow += f;
            edg[i^1].flow -= f;
            flow += f;
            a -= f;
            if(a == 0) break;
        }
    }
    return flow;
}
void work(){
    while(bfs()){
        for(int i = 0; i <= n+1; i++) cur[i] = hd[i];
        ans += dfs(s, inf);
    }
    printf("%d\n", ans);
}

int main(){
    freopen("prog81.in", "r", stdin);
    freopen("prog81.out", "w", stdout);
    init();
    work();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
网络算法可以用来解决最大最小割问题,而飞行员配对问题可以转化成最大问题。下面是一个基于 Python 的网络算法求解飞行员配对方案问题的示例代码: ```python from collections import defaultdict class Graph: def __init__(self): self.graph = defaultdict(dict) def add_edge(self, u, v, w): self.graph[u][v] = w def bfs(self, s, t, parent): visited = set() queue = [s] visited.add(s) while queue: u = queue.pop(0) for v in self.graph[u]: if v not in visited and self.graph[u][v] > 0: queue.append(v) visited.add(v) parent[v] = u return True if t in visited else False def max_flow(self, source, sink): parent = {} max_flow = 0 while self.bfs(source, sink, parent): path_flow = float('inf') s = sink while s != source: path_flow = min(path_flow, self.graph[parent[s]][s]) s = parent[s] max_flow += path_flow v = sink while v != source: u = parent[v] self.graph[u][v] -= path_flow self.graph[v][u] += path_flow v = parent[v] return max_flow def pilot_pairing(pilots, planes): num_pilots = len(pilots) num_planes = len(planes) graph = Graph() source = 's' sink = 't' for i in range(num_pilots): graph.add_edge(source, 'P{}'.format(i), 1) for j in range(num_planes): if pilots[i][0] <= planes[j][0] and pilots[i][1] >= planes[j][1]: graph.add_edge('P{}'.format(i), 'A{}'.format(j), 1) graph.add_edge('A{}'.format(i), sink, 1) return graph.max_flow(source, sink) # 示例用法 pilots = [(1, 5), (2, 4), (3, 6), (2, 5)] planes = [(1, 4), (2, 5), (3, 6)] print(pilot_pairing(pilots, planes)) # 输出为 3 ``` 在上面的示例代码中,我们定义了一个 `Graph` 类来表示图,其中 `add_edge` 方法用于添加边,`bfs` 方法用于执行广度优先搜索,`max_flow` 方法用于计算最大。 在 `pilot_pairing` 函数中,我们首先创建了一个 `Graph` 对象,然后为源点和汇点分别添加一条边,并遍历所有的飞行员和飞机,如果某个飞行员可以驾驶某个飞机,则在他们之间添加一条边。最后调用 `max_flow` 方法计算最大。 在 `max_flow` 方法中,我们首先执行广度优先搜索来寻找一条增广路径,然后计算路径上的最小剩余容量,更新路径上的边的量,并更新最大的值。重复执行这个过程,直到没有增广路径为止。最后返回最大的值。 在上面的示例中,我们输入了 4 个飞行员和 3 个飞机,输出得到了最大为 3,说明有 3 对飞行员和飞机可以配对成功。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值