poj 3274 Gold Balanced Lineup Hash

Gold Balanced Lineup
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13128 Accepted: 3845

Description

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only K different features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits featurei.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input

Line 1: Two space-separated integers,  N and  K
Lines 2.. N+1: Line  i+1 contains a single  K-bit integer specifying the features present in cow  i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature # K.

Output

Line 1: A single integer giving the size of the largest contiguous balanced group of cows.

Sample Input

7 3
7
6
7
2
1
4
2

Sample Output

4

Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

Source




数组sum[i][j]表示从第1到第i头cow属性j的出现次数。

所以题目要求等价为:

求满足

sum[i][0]-sum[j][0]=sum[i][1]-sum[j][1]=.....=sum[i][k-1]-sum[j][k-1] (j<i)

中最大的i-j

 

将上式变换可得到

sum[i][1]-sum[i][0] = sum[j][1]-sum[j][0]

sum[i][2]-sum[i][0] = sum[j][2]-sum[j][0]

......

sum[i][k-1]-sum[i][0] = sum[j][k-1]-sum[j][0]

 

令C[i][y]=sum[i][y]-sum[i][0] (0<y<k)

初始条件C[0][0~k-1]=0

 

所以只需求满足C[i][]==C[j][] 中最大的i-j,其中0<=j<i<=n。

C[i][]==C[j][] 即二维数组C[][]第i行与第j行对应列的值相等,

那么原题就转化为求C数组中 相等且相隔最远的两行的距离i-j


再hash一下。。保证正数。。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
using namespace std;
#define Max 100010
#define MOD 100007
struct Node
{
	int pos;
	int next;
};
Node node[Max];
int hashtable[Max];
int cur,n,k,ans,temp;
int c[Max][32];
bool check(int x)
{
	for(int i=0;i<k-1;i++)
	{
		if(c[x][i]!=c[x][i+1]) return false;
	}
	return true;
}
void init()
{
	cin>>n>>k;
	ans=0;
	for(int i=0;i<MOD;i++) hashtable[i]=-1;
	for(int i=0;i<n;i++)
	{
		scanf("%d",&temp);
		for(int j=0;j<k;j++)
		{
			c[i][j]=temp&1;
			temp/=2;
		}
	}
	for(int j=0;j<k;j++)
	{
		for(int i=1;i<n;i++) c[i][j]+=c[i-1][j];
	}
	for(int i=n-1;i>=0;i--)
	{
		if(check(i)) {ans=i+1;break;}
	}
	for(int j=0;j<k;j++)
	{
		for(int i=0;i<n;i++) c[i][j]-=c[i][k-1];
	}
	cur=0;
}
bool cmp(int a,int b)
{
	for(int i=0;i<k;i++)
	{
		if(c[a][i]!=c[b][i]) return false;
	}
	return true;
}
unsigned int gethash(int x)
{
	unsigned int hash=0;
	for(int i=0;i<k;i++)
	{
		hash+=c[x][i]*(i+1);		//cout<<x<<" "<<i<<" "<<c[x][i]<<endl;
	}
	return (hash%MOD);
}
void searchhash(int x)
{
	int h=gethash(x);
	int next=hashtable[h];
	while(next!=-1)
	{

		if(cmp(node[next].pos,x))
		{
			if(x-node[next].pos>ans) ans=x-node[next].pos;
			return ;
		}
		next=node[next].next;
	}
	node[cur].pos=x;
	node[cur].next=hashtable[h];
	hashtable[h]=cur;
	cur++;
}
int main()
{
	init();
	for(int i=0;i<n;i++) {searchhash(i);}
	cout<<ans<<endl;
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值