找质因数..打素数表..DFS解容斥问题...

Co-prime

Description

Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input

The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output

For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input

    
    
2
1 10 2
3 15 5
 

Sample Output

    
    
Case #1: 5
Case #2: 10

Hint

In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.  

     这题提醒的我就是在求一个数的质因数时..可以先将质数表打出来...10^9内的..质数表只需要扫到32000多(因为32000*32000>100000000了)...最终是打出3000多个质数..但要注意的是..有可能给的数就是质数..或者说有大于32000的质因数..但这样的质因数绝对最多一个...so...见程序.....


Program: 

#include<iostream>
#define ll long long
using namespace std;
ll a,b,n,t,T,x,s[31],M,N,ans,p;
int Prime[40000];
void DFS(ll i,ll w,ll k)
{
      for (;i<=n;i++)
      {
            p=w*s[i];
            M+=k*(N/p);
            DFS(i+1,p,-k);
      }
      return;
}
int main()
{
      freopen("input.txt","r",stdin);
      freopen("output.txt","w",stdout);
      scanf("%I64d",&T);
      ll i,j,num=0;
      for (i=2;i<=33000;i++)
      {
            for (j=2;j*j<=i;j++)
               if (i%j==0) goto A;
            Prime[++num]=i;
            A: ;
      }
      for (t=1;t<=T;t++)
      {
            scanf("%I64d%I64d%I64d",&a,&b,&x);
            n=0;
            for (i=1;i<=num;i++) 
            if (x%Prime[i]==0)
            {
                   while (x%Prime[i]==0) x/=Prime[i];
                   s[++n]=Prime[i];
                   if (x==1) break;
            }
            if (x!=1) s[++n]=x;  // 处理超过32000的质因数
            a--;
            M=0; N=a;
            DFS(1,1,1);
            M=a-M;
            ans=M;
            M=0; N=b;
            DFS(1,1,1);
            M=b-M;
            ans=M-ans;
            printf("Case #%I64d: %I64d\n",t,ans);      
      }
      return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值